Decreasing node memory/bandwidth usage

I am trying to decrease the memory and bandwidth usage of my Zcash node. I have heard that an effective way to do this is to reduce the mempool on your node, or eliminate it entirely. Bitcoin has a config option called “blocksonly” which is supposed to do this. There is another option called “maxmempool,” which is similar but allows some customization. However, when I try running Zcash after adding these options to my config, it doesn’t work.

Are these options disabled for Zcash or am I doing something wrong? How would I go about reducing the size of the mempool on my node? I am interested only in getting new blocks, not unconfirmed transactions.

Thanks.

Zcashd doesn’t have those flags but you might consider opening a ticket for addition in the future: https://github.com/zcash/zcash/issues/new

As of zcashd v2.1.0, there is a mempooltxcostlimit parameter, documented in the 2.1.0 release notes, that bounds the maximum size of the mempool. You may find that the default of 80 MB is adequate. This won’t significantly affect bandwidth usage though.

1 Like