# Error "activating best chain"

**URL:** <https://forum.zcashcommunity.com/t/error-activating-best-chain/1055>\
**Category:** zcashd client\
**Created:** [July 27, 2016, 2:23pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055 "2016-07-27T14:23:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![zawy](https://sea2.discourse-cdn.com/zcash/user_avatar/forum.zcashcommunity.com/zawy/32/11892_2.png) [@zawy](https://forum.zcashcommunity.com/u/zawy)\
**Post date:** [July 27, 2016, 2:23pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/1 "2016-07-27T14:23:54Z")

</div>

On one computer but not the other I get the error message “activating best chain” for a minute or so after startup when trying to do other functions. What does that mean? Why on 1 PC and not the other?

---

<div class="post-metadata">

**Author:** ![zixx](https://avatars.discourse-cdn.com/v4/letter/z/ce7236/32.png) [@zixx](https://forum.zcashcommunity.com/u/zixx)\
**Post date:** [October 24, 2016, 10:54pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/2 "2016-10-24T22:54:29Z")

</div>

I am getting this message too…How to fix this?  
I just started mining today (beta) and now stuck …

---

<div class="post-metadata">

**Author:** ![zixx](https://avatars.discourse-cdn.com/v4/letter/z/ce7236/32.png) [@zixx](https://forum.zcashcommunity.com/u/zixx)\
**Post date:** [October 24, 2016, 11:24pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/3 "2016-10-24T23:24:03Z")

</div>

“If it is still stuck trying to find the chain, go ahead and run a ./src/zcash-cli stop to stop it (or kill the PID with system monitor) and restart it with ./src/zcashd -reindex”

that worked 🙂

---

<div class="post-metadata">

**Author:** ![zixx](https://avatars.discourse-cdn.com/v4/letter/z/ce7236/32.png) [@zixx](https://forum.zcashcommunity.com/u/zixx)\
**Post date:** [October 24, 2016, 11:27pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/4 "2016-10-24T23:27:27Z")

</div>

It worked until another server start…then all over again and again 😑

---

<div class="post-metadata">

**Author:** ![Digitaldonkey](https://sea2.discourse-cdn.com/zcash/user_avatar/forum.zcashcommunity.com/digitaldonkey/32/631_2.png) [@Digitaldonkey](https://forum.zcashcommunity.com/u/Digitaldonkey)\
**Post date:** [October 27, 2016, 5:19pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/5 "2016-10-27T17:19:56Z")

</div>

Same Problem, after upgrading to rc4. First run worked. After it got stuck without any cpu usage. Maybe I need to clean something?

Running  
`./src/zcashd -reindex`

---

<div class="post-metadata">

**Author:** ![Digitaldonkey](https://sea2.discourse-cdn.com/zcash/user_avatar/forum.zcashcommunity.com/digitaldonkey/32/631_2.png) [@Digitaldonkey](https://forum.zcashcommunity.com/u/Digitaldonkey)\
**Post date:** [October 27, 2016, 5:24pm UTC](https://forum.zcashcommunity.com/t/error-activating-best-chain/1055/6 "2016-10-27T17:24:06Z")

</div>

Removing and reindexing solved it

```
rm -rf ~/.zcash/testnet3
./src/zcashd -reindex

```
