Error of Optiminer w/ R9 290x

Hello guys!
I have a rig of two AMD Radeon R9 290Xs.
I have Ubuntu 14.04 installed with latest fglrx
I would like to use Optiminer, but gives back the error:
Segmentation fault (core dumped)
My lspci shows the two VGAs, and I was able to use them with other programs (i.e. Hashcat).
Only thing I suggest, is that I am using it through SSH. Is this a problem? If yes, is there a way to fix it? (I'm often out of the city, so it would be important to make it work through SSH).
Thanks in forward!

Using optiminer through ssh is fine. I do it all the time. Does the miner give any output? What does --list-devices do?

./optiminer-zcash --list-devices
[2017-06-17 20:05:23.780] [info] Optiminer/Zcash 1.7.0 (C) Optiminer 2017
Segmentation fault (core dumped)

The same error

That's strange. Hard to say what is different on your system. Maybe try reinstalling opencl.

Does 'clinfo' work?

good day optiminer

is it any newest version after this from u?

thanks..

$ clinfo
Segmentation fault (core dumped)

Also:

fglrxinfo
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 17
Current serial number in output stream: 18

Also:

$ dpkg -l fglrx

||/ Name Version Architecture Description
+++-==============================-====================-====================-==================================================================
rc fglrx 2:15.201.2-0ubuntu0. amd64 Video driver for the AMD graphics accelerators

To me it seems like there is some problem with fglrx, nonetheless, if I type:

$ sudo apt-get update && sudo apt-get upgrade fglrx

I get:

fglrx is already the newest version.

The system is "brand-new", in a way that I just installed it before leaving town, only installed an ssh-server, nothing else.. When I tested it locally, it worked fine, but not from remote access.. That's why I suspected some issue with SSH.

I be glad for any hints or ideas!

Thanks for the help so far!

When clinfo crashes as well then there is something broken on the system. Does an X server run at all? Does the user have the right permissions? You could try running as root.