Error sending test coins to faucet


#1

Just mined some new testnet TAZ coins. Im trying to send some back to the faucet.

http://faucet.zeropond.com

I am using the following command,

./src/zcash-cli sendtoaddress n4MXbgneZrJKYDQZrAqyeXsXcfgD3KcPqf 1

I am not able to send anything because of this error,

error: {"code":-4,"message":"Error: The transaction was rejected! This might happen if some of the coins in your wallet were already spent, such as if you used a copy of wallet.dat and coins were spent in the copy but not marked as spent here."}

However it did let me send 0.01 TAZ instead of 1 TAZ. Then I tried 0.01 TAZ again without any luck, same error.

Can anyone help me understand why I can send any TAZ? I have over 25 TAZ in my balance.

Thanks!


#2

Huh. Just tried to reproduce it, and i might have broken it.
The balance on the faucet was 35 or so. I sent 1.454 to it to round it up.
All was well, but once transaction succeeded, the balance on the faucet is now 1.454... Exactly what i sent.

WTF?


#3

Ok, it's back to 36.880.
Either it was a coincidence, or they fixed it.

Anyway, it worked for me...


#4

Newly mined coins have to first be sent to a protected address.


#5

I am having the same problem, and it is due to the fact that TAZ must be sent to a protected address 1st.