EWBF 0.3.4b Linux Temp target? GPU HOT

I have 5 NVidia GTX 1070 Founder Editions and 1 1080. Below is the common config settings. The GPUs are hitting 83 degrees Celsius and kept climbing. Is there any way to set temperature targets? I have not had this issue on other Miners like Claymore and Nemos multipool, both of which I ran on the same Linux distro.

cuda_devices 0 1 2 3 4 5
intensity    45 45 45 45 45 45
templimit    75
pec          0
boff         0
eexit        0
tempunits    c
log          0
logfile      miner.log
api          127.0.0.1:42000

Hi,

Here is a copy of my EWBF config (Mint Linux 18.2, Ubuntu derivative):

cuda_devices 0 1 2 3
intensity    64 64 64 64
templimit    75
pec          0
boff         0
eexit        0
tempunits    c
log          0
logfile      miner.log
api          127.0.0.1:42000

You can leave intensity to the maximum (64), I didn’t see any impact on temperature. You have to control fan speed and to activate Nvidia CoolBit on your card (you can google it or check this thread: https://gist.github.com/bsodmike/369f8a202c5a5c97cfbd481264d549e9).

Then, you can limit power consumption and other settings (I run my 1070’s at 85% fan speed, and ~85% power and they run at 60-65­ C).

I have this in a shell script to activate persistance mode (not sure I have to run more than once though…), and set power limits on all cards (nvidia-smi doc.: https://developer.nvidia.com/nvidia-system-management-interface):

# Set persistance mode for all GPU
nvidia-smi -pm 1

# Set GPU Max. power at 160w (86% TDP)
nvidia-smi -pl 160

cd /opt/ewbf-miner
./miner --config ./miner.cfg

Then, you can set fan speed and overclocking settings for each card using something like the following commands:

#!/bin/bash

nvidia-settings -a '[gpu:0]/GPUPowerMizerMode=1'
nvidia-settings -a '[gpu:0]/GPUGraphicsClockOffset[3]=100'
nvidia-settings -a '[gpu:0]/GPUMemoryTransferRateOffset[3]=900'
nvidia-settings -a '[gpu:0]/GPUFanControlState=1'
nvidia-settings -a '[fan:0]/GPUTargetFanSpeed=85'

You have to repeat for each of your card, [gpu:0], [gpu:1], [fan:0], [fan:1], etc. for each card.
Monitor your system for any stability issues and adjust nvidia-settings accordingly. From experience, tweaking GPUGraphicsClockOffset don’t improve performance very much, but GPUMemoryTransferRateOffset does.

Good luck