Fullnode error: "Error: Disk space is low!" Please help me

Hi, my zcash fullnode alert an error: - Error: Error: Disk space is low!
Can someone tell me know how to fix this?

  1. Increase disk size to 500gb
  2. …?
    Thank you so much.



I’m actually in the process of allocating more space on one of machines for the node it runs. It has a 1TB but is dualboot and I have to use gparted to move stuff around or just reinstall an OS which is what I’ll probably do (I like Lubuntu!). You can run it with the .zcash data and zcash params files in an external drive with the datadir= and paramsdir= flag set at start (I think you can run the whole thing externally but idk about the speed). But otherwise yeah more memories

1 Like

If your running with txindex flag set the data storage will consume about double then if it wasn’t set. It limits some of the rpc calls but none that I think people commonly use. LightwalletD requires it however. Changing the setting forces a reindex.

1 Like

Gparted is going! Crossing my fingers because it is inherently risky (I did backup my precious files and folders of course) but it looks good right now. For me it basically amounts to

  1. shrinking the windows partition, I thought to delete because I don’t really use it but I’ll keep it just shrunken
  2. Add the new free space to the target extended partition, will be ‘unallocated’
  3. Move the grub boot sector all the way to the left, it warns you
  4. Resize the specific target partition to take the unallocated space, warns again
  5. Start operations and think good thoughts! It starts moving all your data to it’s new location on disc and takes a little while.
1 Like