Setting clock speed?

Hi
I'm trying to try out different clock speeds but only 1 card takes the setting.
I'm running windows 10 - 15.12 drivers. have 1 R9 290 3xHD 7950
I was using nicehashminer and added this switch -cclock 1000 for the 290 which is the first GPU, when I restarted Nicehash, the last GPU (7950) started running 1000 and the 290 showed the default setting of 947. I removed the switch and the 7950 still ran at 1000. As it ran better I added -cclock 1000 to all 4 GPUs but the other 3 stayed on their default clocks? The logs look like Nicehash was passing the parameters over without errors.

I tried removing nicehash from the equation and added the below to the start.bat file and ran it. Still only the last GPU ran at 1000 and the others at their default speeds. Techpowerup shows all the cards changing fan speed to stay at 86C so that works?

ZecMiner64.exe -tt 86 -cclock 1000,1000,1050,1000 -mport -4000 -zpool stratum+ssl://equihash.hk.nicehash.com:33357 -zwal 1Dn35LvyAzkuTk3WD7zSZ3wTTURh8FAFnE.worker1 -zpsw x

any suggestions would be appreciated - Thanks in advance - also the remote admin port keeps changing to anything between 4000 to 4020 when I keep restarting the miner - though that's not a bit issue :slight_smile:

What version of nicehashminer are you using? I am only slightly familiar with nicehashminer, but I believe you can only set speeds her by hard code in bio's or using msi after burner or AMD's version. again I have only used NHM for testing, so my knowledge on it is limited.

Zecminer- there is a known bug in zecminer that the gpu placement and the config setting placement are usually different.
meaning gpu3 could actually be the first position in the settings -cclock yes,no,no,no

change one at a time from stock to whatever to see which config slot equals which gpu.

me I used -fanmin 100,0,0,0 or -fanmin 0,100,0,0 , etc this way whichever gpu was running the coolest (and loudest) I could determine (without a doubt) placement.

I've got the latest version of nicehashminer 1.7.4.1 though I don't think it's causing the problem (nor zecminer) as using zecminer directly has the same issue.

yeah it does look like the gpu placements aren't correct in zecminer.

I've tried -cclock 1000 expecting all of the gpus to run at 1000 but only the last one does.
I tried -cclock 1000,1000,1050,1000 to see if 3 would run at 1000 and 1 at 1050 but still only the last one ran at 1000.
I removed the switch altogether expecting the last one to go back to it's default of 800 but it still ran at 1000, even after a reboot.

I don't want to risk setting the fan at 100 in case it gets stuck at the level too :slight_smile:

looking at my rig I have a feeling it's something wrong with software on it - I tried installing the full app Radeon-Crimson-15.12-Win10-64Bit and when I open it and click on the tabs they're grey and empty - I can't see the cards or any writing. I originally ended up uninstalling it and installing just the drivers for the cards.

Zecminer works pretty well.
GPU0 283.775 H/s, GPU1 228.457 H/s, GPU2 201.385 H/s, GPU3 218.945 H/s
R9 290, Sapphire HD 7950, Sapphire HD 7950, Sapphire(clock at 800) HD 7950(clock at 1000)
The 1st 7950 is a better model than the last two 7950's. Those two are identical so if I can change the clock I could get a little more sol's out of it.