Trying to build on ARM

Yes this is exactly what happened with me and was repeatable after starting again from scratch. At that point after a couple tries, I gave up and simply copied over a data directory to get it running.

I also tried syncing on Amazon a1 instances https://aws.amazon.com/ec2/instance-types/a1/. The a1.medium (1 CPU, 2GB RAM) didn’t work (albeit I didn’t enable any swap) but the a1.large (2 CPU, 4GB of RAM) worked great so I think the Pine64 should work really well and the Odroid C2 is right on the edge.

2 Likes

I’d also recommend https://github.com/netdata/netdata to monitor your system. It’s super lightweight and gives a great visual overview of how your system is running.

2 Likes

I have a plan, its a plan so cunning that if it had a tail it’d be a fox…

Started up again with a much smaller dbcache size (8) - the default is 450 - with a little luck that’ll free up enough resources to get through the sync.

2 Likes

First time I tried. Very nice indeed !

So far so good.

It finished ‘Activating best chain’, got through block 48109 and is back to syncing mainnet. Memory use with dbcache=8 is approx 50%

1 Like

Great stuff, that will be amazing if this completes.

Seems the Pi3 power supply cant quite handle the external drive.

zcashd died with a ‘database corrupt’ message & there were ‘under-voltage’ warnings in the kernel logs, probably have better luck with a SSD.

1 Like

This happens because updating the metrics screen requires locking on cs_main, and if the node is busy processing a particularly-large block, it will end up holding that lock until the block is finished, meaning that the UI will hang until its done.

3 Likes

I remember you could increase the power supply to USB ports. Maybe you tried this already ?

242k blocks … still no crashes and still syncing … :slight_smile:

2 Likes

You’re doing better than me, had to reindex to recover mine (took all night), now syncing block 84500.

Running as a daemon, doesn’t save many resources but every little helps.

(Edit: The Pi3B+ is syncing approx 10k blocks an hour)

1 Like

Ok, I’ve got str4ds version compiled on my main Ubuntu box. I’m not sure what exactly in the ./src folder needs to be replaced on the Rock64.

I did the normal git checkout and fetch params on the Rock64 but didn’t run the builder.

I got it working! :laughing: Thanks to @garethtdavies for info about the Binaries it’s now syncing up.

5 Likes

Now my next project is making a custom Zcash case for it…

Once I finish the CAD I’ll 3D print it and upload the data it to thingverse so anyone can use it.

6 Likes

Good luck with syncing!
My Odroid C2 is still busy… Reached block 334144.
Stable but slow

1 Like

Mine crapped out around block 115000, the Pi3B+ power supply doesn’t have enough grunt to run my external hard drive, which is essential for a swap file. When swap activity increased from digesting larger blocks there wasn’t enough power left to run the Pi.

I had it running for a while with swap enabled on the SD card (epicly bad idea!), it worked but was very slow. I’m going to hack the USB cable so the drive can have its own power supply & try again.

(Edit: Overclocked the SD card (heh!) & stole some RAM back from the GPU…trying again)

3 Likes

Not too bad so far, average 721mb RAM use, 26k blocks. But it’s going to take me a while no matter what because I live in a rural area with embarrassingly slow internet speeds.

It has 4GB of RAM, (3.79 free with LXDE desktop) so hopefully it won’t choke on the big blocks.

If you have another node (I’m guessing you do), use ‘zcash-cli addnode’ & you can slurp blocks from that… should speed it up.

I came home to find that the node had stopped at 49K blocks and had no connections. :neutral_face: I’m not sure what happened but the entire board lost internet sometime last night or early this morning.

So I re-booted the router and the board and now everything is back to normal… so far…

I could just copy the blockchain from one of my other nodes, but I was hoping to find out what a new user would experience if doing this for the first time.

2 Likes

Think ‘addnode’ will preserve the 'new user experience, it’ll just use a faster/local node as one of its sources.

Copying the blocks is cheating! :roll_eyes: