Zcashd execution error post install

Hello from a new user (almost),

Might be a simple problem but I can't seem to solve it.

I have installed zcash from binary tarball, on Debian 64bit on a Virtual Machine as per instructions.

when I attempt to run:

$ zcashd

I get:

cannot execute binary file: Exec format error

and when I do:

$ sudo zcashd

I get the following error:

1: /usr/local/bin/zcashd: Syntax error: "(" unexpected

Is there an obvious solution to this?

Thanks

Zcashd is located in the Zcash folder so first step is to enter zcash directory with
cd zcash
then
./src/zcashd to start the node.

Once you see the screen with :zcash::heart: wait for it to finish syncing with the network (check nodes blockheight)

Open another terminal window, cd zcash then you can run commands like ./src/zcash-cli getinfo

Here is a list of other commands you can use https://github.com/zcash/zcash/blob/master/doc/payment-api.md

Many thanks Shawn,

To clarify, I followed the instructions here:

https://z.cash/download.html

The directory seems to be named zcash-1.0.9 and the zcashd binary is at /usr/local/bin/

Is this correct?

I've tried cding into the above zcash directories, I still get the same error.

Please forgive me if this is something obvious,

Thanks

L

Just to add, the

zcash-fetch-params

command seemed to work ok.