Benchmarks on multiple CPUs - only 1 core used


#1

Hi All,

I've been trying to benchmark a 4-core system, but I can only see one CPU being active.

My config file:

testnet=1
addnode=betatestnet.z.cash
rpcuser=rpcusername
rpcpassword=rpcpassword
gen=0
genproclimit=4
equihashsolver=tromp

I think the relevant bits are: gen=0 and genproclimit=4. I have also tried with genproclimit=-1 and it didn't help.

This is how I am running the benchmark
zcash-cli zcbenchmark solveequihash 20

My questions in particular are:
- Should I be setting gen=0?
- Is there another parameter that I need to pass to the benchmarking tool to indicate a number of cores?

I am running the 1.0.0-rc2 branch of the "vanilla" miner.

thanks


#2

You need to have gen=1 to be mining, gen=0 is just running the node. Once you switch that you should be good to go.


#3

i think when you use zcashd setgenerate false , that would set zcashd stop mining ,and be a node hosting only mode.(which you can prove by use that gui wallet software with dependency zcash node). that wallet still working


#4

Thanks @Shawn and @privatenode.

I guess then my question is: Does that mean that I need to keep mining when I am benchmarking?

If I run the
zcash-cli zcbenchmark solveequihash 20
with the
gen=0
in my config, I still get some meaningful (and quite sensibly looking) output, but during the benchmark only one cpu is active.


#5

You shouldn't be mining when benchmarking, the benchmark always only runs on a single thread, so its not super accurate for total sysem performance. But when you are done benchmarking all you have to do is change gen=0 to gen=1 to begin mining.


#6

OK, I guess I probably misunderstood your previous post then. So, to do the zcbenchmark I have to set gen=0.

So, is there no way to use the zcbenchmark tool to test a multiple CPU system?