Compiling causes computer to freeze ( 1.0.0-rc2,)


#1

I don't know if this has been happening to anyone else but ever since the new release candidate 1.0.0-rc2 every time I try compiling my computer freezes.


#2

Are you running on Linux or VM?


#3

A Linux VM. It didnt freeze before the update.


#4

I'm no expert with VM, but you may need to dedicate more RAM to it. I know on a Linux OS you can get by with 4GB but I'd imagine you need quite a bit more there...


#5

Ok. Thanks. I don't understand why it was working before I tried to update though.


#6

Who knows, but you should always double and triple check all of your typing before messing with hardware, I've learned.


#7

Yeah I've read that somewhere and I may be learning from experience also


#8

Another thing you could try is compiling without the -j$(nproc) flag. This will compile one file at a time and use less memory (if it's memory that's the issue)


#9

Thinks I will give that a shot.


#10

Maybe you can help with THIS


#11

./zcutil/fetch-params.sh
The rc2 release resets the testnet block chain, so you will also need to recursively delete your testnet3 directory, like this:

$ rm -rf ~/.zcash/testnet3


#12

THis is the same user you were talking to a second ago on a different topic. I did delete the testnet3d irectory but it still kept freezing so I started a new VM and now I'm getting Makefile:640: recipe for target ‘all-recursive’ failed (error1) during compiling


#13

unbuntu 16 instead of 14


#14

yes do you think that is the problem


#15

its been reported as one


#16

step one
sudo apt-get install \
build-essential pkg-config libc6-dev m4 g++-multilib \
autoconf libtool ncurses-dev unzip git python \
zlib1g-dev wget bsdmainutils automake

step 2
$ git clone https://github.com/zcash/zcash.git
$ cd zcash/
$ git checkout v1.0.0-rc2
$ ./zcutil/fetch-params.sh

step 3 $ ./zcutil/build.sh -j$(nproc)

Ensure you have successfully installed all system package dependencies as described above. Then run the build, e.g.:
This should compile our dependencies and build zcashd. (Note: if you don't have nproc, then substitute the number of your processors.)

should have working zcashd

then build miner

sudo apt-get install \
cmake build-essential libboost-all-dev
Clone and checkout the repository
git clone https://github.com/razakal/nheqminer.git
Compile nicehash equihash miner
cd nheqminer/nheqminer
mkdir build
cd build
cmake ..
make


#17

if error about qt

sudo apt-get install qt5-default


#18

I haven't tried the standalone miner yet but switching to Ubuntu 14 worked. Everything compiled and started up fine. Thinks


#19

awesome glad i could help