Error while installing zcash on my system

It sounds like you would benefit from using the testnet or regtest like mentioned. It would allow you to potentially test whatever changes you need to make and acquire test coins to transact.

Thanks for the reply,

Can you help me, how to use testnet/ regtest ? Do shielded/unshielded transactions ? How to make changes and see changes are working or not?


You can enable testnet in the zcash.conf with ‘teatnet=1’. You can also set ‘gen=1’ to mine testnet blocks, check the /zcashd/docs/man for info on config and zcash-cli usage.

Can you paste the complete url where i can find this repository? ( /zcashd/docs/man )… Hey if possible can we meet on google meet?


I was getting following error while running zcash wallet operations
link used for setting up the network :

following is the command used : ./zcashd -regtest -daemon -datadir=/home/zcash/zcash/gargmohi/regtest/data/


Once reindexing is complete then that call should work.

Is it happening on the network? My team is working on a project where everyone is encountering the similar issue ( all are using regtest mode) .

Reindexing is a normal function of the node. It means that it is downloading and reverifying the block chain. Weather it is specifically because of the regtest option that you’re running I’m not sure, but it typically takes a few days normally.


It’s been more than a week since I’ve been trying on different machines and yes, on regtest mode. But I’m still seeing this error.

root@314c339dca4f:/mohit_zcash/zcash/src# ./zcash-cli -rpcuser=gargmohi -rpcpassword=gargmohi619 -datadir=/mohit_zcash/zcash/mohit/regtest/data getbalance
error code: -28
error message:
This wallet operation is disabled while reindexing.

Can you please help or ask someone who could.


1 Like

Is this running as a daemon or can you see the progress? Does getinfo work?

above iss the screenshot for the getinfo

Ok, let me try to help … You need to generate some blocks, your height is 0 (genesis). Keep in mind that network upgrades are not automatically activated in regtest mode, you have to do it manually with nuparams option. For example, if you want to activate NU5 at height 5, you should use nuparams=c2d6d0b4:5 in your conf file. For “mining” blocks in regtest you should use generate RPC command followed by the count of blocks you want to produce. As soon as you generate more than 100 blocks in total (coinbase maturity) you’ll see your mature balance.


it seems like u use zcashd 5.3.0 ? since its 1 year old it might be problematic.
maybe try the newest one 5.7.0 Release v5.7.0 · zcash/zcash · GitHub

1 Like

I didnt even see that (^^)d

Hi, i made teh recommended changes ( currently i’m on 5.7.0 branch) but they are not working i.e. to increase the height of block. ( generateblock is not working) due to same reindexing error.

1 Like

I suggest deleting /mohit_zcash/zcash/mohit/regtest/data/regtest folder contents, to start “clean” regtest chain.
Peek 2023-12-01 09-51


Hi @miodragpop , the process you suggested worked yesterday. i have created a transparent address zcash transfer. But when i restarted by zcash today and use wallet related opertations like getbalance, sendtoaddress API’s i still observe the same reindexing error.

So i tried to reindex while starting the zcash with below command, and in the debug.log i could see reindex is complete. But still i see the same reindexing error.
src/zcashd -regtest -daemon -reindex -datadir=/home/vinni/avineeth/Zcash_work/zcash/vinni/

debug.log prints:
2023-12-04T14:50:22.701169Z INFO main: msghand thread start
2023-12-04T14:50:22.701176Z INFO Init: main: init message: Done loading
2023-12-04T14:50:22.701337Z ERROR Init: main: ContextualCheckTransaction(): overwinter is not active yet
2023-12-04T14:50:22.701370Z ERROR Init: main: ContextualCheckTransaction(): overwinter is not active yet
2023-12-04T14:50:22.701376Z ERROR Init: main: ContextualCheckTransaction(): overwinter is not active yet
2023-12-04T14:50:22.701378Z ERROR Init: main: ContextualCheckTransaction(): overwinter is not active yet
2023-12-04T14:50:22.767745Z INFO main: Loaded 113 blocks from external file in 82ms
2023-12-04T14:50:22.767822Z INFO main: Reindexing finished
2023-12-04T14:50:22.792543Z INFO main: Pre-allocating up to position 0x100000 in rev00000.dat

could you please help here. Thanks!

1 Like

1 Like

As @Autotunafish hinted, if you want to reuse your regtest chain data, make sure you use the same consensus rules each time you start zcash daemon. Network upgrades activation has to occur at the same heights on each run, as set by nuparams option. I don’t see nuparams option in your command line, so I presume you’ve forgotten it or it’s written in zcash.conf. If it’s in zcash.conf and you suddenly decide to start using another workdir, be sure to copy configuration file to that new working directory prior to next zcashd start. Also, if you are part of the team and you want to share the same blockchain via network, you’ll have to add each other’s ip address manually with addnode options.

1 Like