Miner- Optiminer/Zcash GPU miner v1.7!

Can somebody help me with this?
./optiminer-zcash: error while loading shared libraries: libOpenCL.so.1: cannot open shared object file: No such file or directory

Got in error in Windows 7

2016-11-13 09:25:09,382 INFO [default] Optiminer/Zcash 0.3.1 (C) Optiminer 2016
2016-11-13 09:25:11,009 ERROR [stratum] Failed to connect to eu1-zcash.flypool.org:3333
2016-11-13 09:25:11,009 WARN [stratum] disconnecting
2016-11-13 09:25:11,011 INFO [stratum] Retrying connecting to eu1-zcash.flypool.org in 20 ms.
2016-11-13 09:25:11,907 INFO [GPU0] Using device 'Tahiti
2016-11-13 09:25:11,909 ERROR [default] OpenCL error: Failed to read bin/X-base.bin (-1)

Oh sure. It’s worked on SAv5

You have to install AMD SDK 3 to get OpenCL.
If you installed that, create a symlink to the file.

Have a look at the Github page of the miner.

Failed to read bin/X_base.bin

You need to run the miner from the directroy where optiminer-zcash is in
otherwise it will not find the opencl kernel.

Im getting a cygwin1.dll error

Does this work with suprnova? I keep getting an error about how it can’t find that host.

I have set SDK 3.0, but i forgot how to tell him

1 Like


That’s all I changed in the VBIOS.

You can get my roms here:

Hello Optiminer, this looks great, does it work with ZCL?

I use it on Suprnova.cc
Check the address. Should look as simple as this:

./optiminer-zcash -s zec.suprnova.cc:2142 -u AnorakSupra.Rig1 -p x

Ah thanks! I was using the stratum+tcp before the rest of the host which caused it to not work.

Did you set up the SDK using sudo? It has to be installed in the /opt folder.

Check your environment settings with

$ env | grep opt

You should have a line like this:


If not, reinstall the SDK using:

$ sudo ./ AMD-APP-SDK-v3.0.130.136-GA-linux64.sh

What do you mean? I am running it in the same directory that I put optiminer-zcash dir, otherwise it wouldn’t find the ./optiminer-zcash.exe file
the X_base.bin is inside a folder called “bin”

Thank you, problem solved

1 Like

2016-11-13 19:41:33,517 INFO [default] GPU1: Share accepted! (95/96)
2016-11-13 19:41:33,570 INFO [default] GPU1: Share accepted! (96/97)
2016-11-13 19:41:34,139 INFO [default] GPU3: Share accepted! (97/98)
2016-11-13 19:41:34,180 INFO [default] Total 399.0 I/s 773.0 S/s (1s)
2016-11-13 19:41:34,191 INFO [default] GPU0 80.0 I/s 147.0 S/s (1s)
2016-11-13 19:41:34,257 INFO [default] GPU0: Share accepted! (98/99)
2016-11-13 19:41:34,360 INFO [default] GPU2 79.0 I/s 146.0 S/s (1s)
2016-11-13 19:41:34,374 INFO [default] GPU3 78.0 I/s 147.0 S/s (1s)
2016-11-13 19:41:34,390 INFO [default] GPU1 80.0 I/s 168.0 S/s (1s)
2016-11-13 19:41:34,415 INFO [default] GPU2: Share accepted! (99/100)
2016-11-13 19:41:35,050 INFO [default] GPU4 78.0 I/s 153.0 S/s (1s)
2016-11-13 19:41:35,164 INFO [default] GPU2: Share accepted! (100/101)
2016-11-13 19:41:35,218 INFO [default] GPU0: Share accepted! (101/102)

1 Like

How to enable extranonce?

Run install Cygwin, it won’t either way however.

So you propose to use some other miner which gives 50% hashrate? :wink:

I already have Cygwin, reinstalled same thing.