Mining confusion


#1

First of all, let me say that i am glad to be a part of zcash community.

As of recently, i think i set up my zcash properly. Meaning i can run the deamon, and i can work with zcash cli. However, i have some questions. I have sent some test zcash coins, from the faucet which was specified in the set up guide on github. However, as of yet i have recieved no coins.
I am not sure if i am not just impatient or is there an actual problem somwhere.
The same happens with the mining. I changed the config file. Started the daemon, and now i am mining. (I think) But there are no transactions yet.

Oh, and how do the mined coins get to my wallet address ?
I have generated both public and private address, and i have set up for everything mined to be sent to one address.

When i run the "listunspent" command, i get the following output : "[]".

And my config file looks like this :
"
testnet=1
addnode=betatestnet.z.cash
rpcuser=username
rpcpassword=password
gen=1
genproclimit=-1
"

Like i said i am not sure if i am just impatient, or i did something wrong.


#2

To be sure your mining use
~/zcash/./src/zcash-cli getinfo
If connections - 1 you are ok
also check
~/zcash/./src/zcash-cli listtransactions
This shows the mined coins.

If
[
]
you havent found a block yet

Give it 12-24hrs you should find a block or more


#3

check node connection with

~/zcash/./src/zcash-cli getinfo

after a wile depending on your hashing power you will get some blocks you can see as "immature" transaction until get 100 confirmation ... use

~/zcash/./src/zcash-cli listtransactions

when state change to "generate" you can see transaction whit

~/zcash/./src/zcash-cli listunspent


#4

Total balance

./src/zcash-cli z_gettotalbalance


#5

may be has 0 balance ... now i will going to send some ZEC

i hope this will solve


#6

now has 3 TAZ

can check in the future with this link

https://waterhole.io/zcash/address/n4MXbgneZrJKYDQZrAqyeXsXcfgD3KcPqf


#7

Guys, thank you for your help, i was just impatient, it seems i really did set up everything as i should, i just needed to wait a bit, since it seems my PC is a bit slow.


#8

when I run /zcash/./src/zcash-cli listtransactions or ./src/zcash-cli listunspent I get empty brackets:

[
]

any idea why ?

b.r.