Trying to build on ARM

#45

I use a 16gb emmc module instead of an sdcard and gave it an extra 2gb SWAP space on the emmc. It’s much faster than the sd card…
It never went above using 1,2gb of swap space…

I use an old external HDD that has its own power supply hooked to USB and holds the /zcash folder.

Beside this, it’s also used as AFP and DLNA server.
Everything runs smoothly so far.

I am tempted to start again with an image of ubuntu server.
I had troubles building keybase and after that attempt, everything became very slow, with only 2 connections… Then after a reboot, everything went back to normal.
I’d even say that it somehow speeded up the sync. the last ~150k blocks went very fast.

For the moment, I’ll have it running for a while, see how it goes…

#46

Thanks for that, that’s helpful. I’m using EMMC too so it shouldn’t be that. I only have 1GB of zram that was pre-configured (so that might just not be enough). I think I’ll try 2GB of swap and retry.

My Raspberry Pi nodes are running incredibly smoothly so it’s just the initial sync that’s the major constraint :+1:

1 Like
#47

Yeah, I have a very small 30mm fan I can use, I’m holding off until the initial sync is complete then I will be able to disconnect it to fiddle with the case design. Maybe just mounting the fan firing upwards and drawing air through the sides would be enough.

2 Likes
#48

Aaarrrghhh… Pi3B+ sync died again :unamused:

Plan C - starting over, 8Gb swapfile on the SD card, SD card overclocked, using NAS storage instead of the external USB drive.

#49

The zram somehow wasn’t being used by the zcashd process… That’s at least what I thought I could see via “top” command before zcashd crashed…
Maybe because it is split in 4 different entities?

Before the odroid C2, I had an old fitpc2 with 4gb of RAM. That was enough to have it running. So I guess a total of 4GB of ram is what is needed…

#50

Woo! :star_struck: Finally synced. Had a couple hiccups like a power outage and keep dropping connection due to my crummy internet but it’s complete.

At the big blocks (350,000 or so) it used a peak of 2.3GB of RAM to crunch through.

5 Likes
#51

So now, next challenge: How to update to 2.0.4? :slight_smile: Should we cross compile and over write the files? Or can we use the update command line tool?

#52

Yes. You’ll need to rebase #3505 on master and then cross compile and simply replace the binaries.

If you mean updating via the package manager then this isn’t supported.

2 Likes
#53

I just wrote this post summarising the current state now that support has been merged into master. Any suggestions/errors/omissions are welcome :smile:

4 Likes
#54

Nice, I was just thinking about this. My little node has been running for over a month now without any issues :blush:

2 Likes
#55

My attempts to sync mainnet on a Pi3B+ have failed (so far). Probably just the usual power supply issues, its right on the limit with an external USB drive.

I’d like to be sure it can verify a large/full block, eventually we’ll get some of those & could be a problem - 1Gb ain’t much.

Haven’t given up yet, just busy with other stuff.

#56

I’ve a couple of Pi nodes that have now been running over a month uninterrupted (one on testnet and one on mainnet). I’ll have a check to see if there have been any large/full blocks during that period :thinking:

I’m just completing the sync on the Odroid C2 (60k blocks to go) and it’s slow going.

2 Likes
#57

I came across the Jetson Nano the other day, looks pretty cool for $99 https://developer.nvidia.com/embedded/buy/jetson-nano-devkit

1 Like
#58

If only the Pi came with a memory socket (sigh), often wondered why they didn’t do that, laptop memory is cheap & small.

1 Like
#59

Same here, my odroid c2 has been running since then without a flaw … :slight_smile: The combination of ARM+eMMC for main system and SWAP + big HDD via USB for chain is working fine :slight_smile:
@garethtdavies, Have you tried ubuntu server ARM downloaded directly from ubuntu official website on your odroid c2, or a special build on hardkernel pages?

That page could be usefull to find a better suited single board computer:

1 Like
#60

I haven’t currently tried either. I’m just using Armbian but I’d probably go the Ubuntu route if I were to do this again. I think I’m going to have to get an N2 :laughing: so I’ll give it a shot on that.

#61

Looking right now at another one but trying to refrain myself … I still have an unused raspberry 3 B+ in its box, and 2 other ones running as music players … It’s an invasion … :slight_smile:

#62

Hello,

I have one question… by mistake I 've sent Zclassic coins to my Zcash addres of my ledger nano s wallet in chrom app.

Did i lost my coins permamently ?

Thank you in advance for the feedback

Your kind support will be appreciated
Best regards

#63

T̶h̶i̶s̶ ̶i̶s̶ ̶a̶ ̶b̶i̶t̶ ̶o̶f̶f̶ ̶t̶o̶p̶i̶c̶ ̶@̶M̶i̶c̶h̶a̶e̶l̶1̶9̶8̶5̶,̶ ̶b̶u̶t̶ ̶y̶e̶s̶,̶ ̶y̶o̶u̶r̶ ̶f̶u̶n̶d̶s̶ ̶a̶r̶e̶ ̶l̶i̶k̶e̶l̶y̶ ̶l̶o̶s̶t̶ ̶s̶i̶n̶c̶e̶ ̶y̶o̶u̶ ̶d̶o̶n̶’̶t̶ ̶c̶o̶n̶t̶r̶o̶l̶ ̶t̶h̶e̶ ̶p̶r̶i̶v̶a̶t̶e̶ ̶k̶e̶y̶s̶ ̶t̶o̶ ̶t̶h̶a̶t̶ ̶a̶d̶d̶r̶e̶s̶s̶ ̶o̶n̶ ̶t̶h̶e̶ ̶Z̶c̶a̶s̶h̶ ̶B̶l̶o̶c̶k̶c̶h̶a̶i̶n̶.̶

EDIT: this is not accurate info, see the below comments.

#64

Dear Shawn,

Sorry for the confusion with the topic.

One more thing… so even when I use ledger nano s for zclassic and zcash then I’m still not able to get access to the coins ?

Thank you in advance for the feedback