Zcash build problem


#1

Hi folks, I'm trying to build zcash on Debian Jessie (amd64) and I'm running in to a problem.

I cloned libzerocash from github and got the branch called zc.latest.0, commit b67adce2, and built it. I then cloned zcash from github and got the branch called zc.v0.11.2.latest, commit 2553facb.

When I tried to build zcash, i got this error:

primitives/transaction.cpp:12:36: fatal error: libzerocash/PourProver.h: No such file or directory

Sure enough, libzerocash does not contain PourProver.h. Maybe someone forgot to push some commits?


#2

Sigh. I hit this exact same problem when I tried to build it myself! The answer is, you need a different fork of libzerocash, but https://github.com/Electric-Coin-Company/zcash/wiki/Public-Alpha-Guide should fetch it for you. The real answer is that we need to copy the right version of libzerocash into the zcash codebase ASAP and eliminate this troublesome dependency-management.


#3

I guess you'd want to fork libsnark, libsnark-supercop, ate-pairing, and xbyak too. :disappointed:


#4

That wouldn't be necessary, because there are no changes we need to make to those dependencies (or if there are then we would just push them upstream).