Activating best chain // missing directory

This is my first post on this forum. I'd like to thank this community for providing user friendly guides to a broader audience who might not otherwise be able to participate on zcash.


As for this post.. I've been using zcash for a few months now, and have been able to troubleshoot fairly well when running into problems.

I recently received some coin to my t-address, and multiple z-addresses. The block explorer showed that the coin was in these addresses, yet my wallet, despite appearing to be fully synced, was not reflecting the balance.

I waiting overnight, and checked again approx. 12 hours later, and still saw no balance in any of the receiving wallets.

I then came to these forums, and after reading a few threads, decided to try the command zcash-cli -reindex.

Since type that command in, my client has been stuck on "Activating best chain..." I've tried restarting the client several times, running it in daemon mode, and have let it sit for over 15 hours. It returns to "Activating best chain..." despite what I do.

zcash-cli commands are no longer working, as it only responds with
error: {"code":-28,"message":"Activating best chain..."}

I have also searched for my wallet.dat and conf files on my virtual machine, but searching the file system, it cannot seem to find them. In fact, I cannot find my zcash directory at all to back up any of the files. Yet despite not being able to find the directory, zcash seems to still be running....somewhat.

Any help would be sooooo appreciated.

I'm running Ubuntu 16.04 64x

they should be in ~/.zcash/ and you should backup wallet.dat ASAP!

I admit to being a bit of a noob with Linux in general, and also with zcash. It is definitely a learning process.

So I solved my problem, which was helped significant by a post of radix42's in another thread as follows:

copy ~/.zcash/wallet.dat and ~/.zcash/zcash.conf somewhere else

Nuke the ~/.zcash directory

run mkdir ~/.zcash, copy zcash.conf and wallet.dat back into it and start zcashd again

Previous to starting my own thread, I could not find ~/.zcash for the life of me. Normal searches in my directory turned up no /.zcash folder at all. But it appears that it is a hidden folder and thats why I could not find it.

My directory could be accessed with:

cd /home/user/.zcash

And to open the directory, I used:

nautilus /home/user/.zcash

From there, I was able to backup the entire folder, and followed radix42's advise, deleting the directory after it had been backup up, making a new directory in the same place, and placing my wallet.dat and zcash.conf back in the new folder.

Then, starting zcash as normal, the blockchain synced, I was no longer stuck on {"code":-28,"message":"Activating best chain..."}, and all of my wallets are present with their correct balances.

All of this probably comes off as obvious and simple to most, and in retrospect it feels that way to me now. But at the time, when the issue was still unresolved, I couldn't see it.

I'm posting what happened with the hope that if someone runs into a similar issue in the future, and are new to this like myself, it will be of some use.

1 Like

fyi, the tilde character "~" is shorthand on unix/linux for "the current user's home directory", which gets expanded to /home/your-username by the shell