Build error zcash v1.0.0 ubuntu desktop 16.04


#1

Hi

When trying to build zcash 1.0.0 on Ubuntu desktop 16.04 in VMWare Player I get the following build error. Any pointers on resolving would be MUCH appreciated.

--

Making all in src
make[1]: Entering directory '/home/rbblue/zcash/src'
make[2]: Entering directory '/home/rbblue/zcash/src'
/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/share/../native/bin/ccache g++ -m64 -DHAVE_CONFIG_H -I. -I../src/config -I. -I./obj -pthread -I/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/share/../include -I./leveldb/include -I./leveldb/helpers/memenv -I/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/include -I/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/include -I./secp256k1/include -I/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/share/../include/libsnark -I/home/rbblue/zcash/depends/x86_64-unknown-linux-gnu/share/../include/ -DBOOST_SPIRIT_THREADSAFE -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -std=c++11 -pipe -O1 -fwrapv -fno-strict-aliasing -Werror -g -Wformat -Wformat-security -Wstack-protector -fstack-protector-all -fPIE -MT libbitcoin_server_a-main.o -MD -MP -MF .deps/libbitcoin_server_a-main.Tpo -c -o libbitcoin_server_a-main.o test -f 'main.cpp' || echo './'main.cpp
{standard input}: Assembler messages:
{standard input}:200968: Warning: end of file not at end of a line; newline inserted
{standard input}:202299: Error: unknown pseudo-op: `.l'
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
g++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See for instructions.
Makefile:4047: recipe for target 'libbitcoin_server_a-main.o' failed
make[2]: *** [libbitcoin_server_a-main.o] Error 4
make[2]: Leaving directory '/home/rbblue/zcash/src'
Makefile:7453: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/rbblue/zcash/src'
Makefile:640: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1

--

Thanks!


#2

I've got it too.. do you already found solution?


#3

I had some build errors on ubuntu 16.04 too. In my case it was due to running out of memory because of a badly installed stick of RAM in my case, but perhaps it has something to do with a memory setting in the vm?


#4

Had the same error building on a 2GB linux cloud instance.

I then tried compiling on my 16GB ram mac and it worked.

Maybe it's a memory issue?


#5

Thanks. Increasing the VM ram from 1GB de 6GB solved the problem.