Can not connect to Zcash's node


#1

I found that my system can not connect to the Zcash today.
But my PC is online and can reach any websit. How can I to slove it?

zheng@ubuntu:~/zcash$ ~/zcash/./src/zcash-cli getinfo
{
"version" : 110200,
"protocolversion" : 70002,
"walletversion" : 60000,
"balance" : 40.00000000,
"blocks" : 18314,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 0.00001121,
"testnet" : true,
"keypoololdest" : 1466068452,
"keypoolsize" : 105,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "WARNING: check your network connection, 0 blocks received in the last 4 hours (24 expected)"
}
zheng@ubuntu:~/zcash$ ~/zcash/./src/zcash-cli getwalletinfo
{
"walletversion" : 60000,
"balance" : 40.00000000,
"unconfirmed_balance" : 0.00000000,
"immature_balance" : 320.00000000,
"txcount" : 43,
"keypoololdest" : 1466068452,
"keypoolsize" : 105
}
zheng@ubuntu:~/zcash$ ping www.ifeng.com
PING c.xdwscache.ourglb0.com (183.61.26.199) 56(84) bytes of data.
64 bytes from 183.61.26.199: icmp_seq=1 ttl=56 time=12.3 ms
64 bytes from 183.61.26.199: icmp_seq=2 ttl=56 time=13.0 ms
64 bytes from 183.61.26.199: icmp_seq=3 ttl=56 time=12.9 ms
64 bytes from 183.61.26.199: icmp_seq=4 ttl=56 time=12.6 ms
64 bytes from 183.61.26.199: icmp_seq=5 ttl=56 time=12.8 ms


#2

You must update to new release, look at this thread:


in short:
git fetch origin
git checkout zc.v0.11.2.z5
Build:
./zcutil/fetch-params.sh
./zcutil/build.sh -j8
Delete old testnet data: rm -rf ~/.zcash/testnet3/


#3

Thank you very much.


#4

I just do according to your prompts. But I have another problems now. Please kindly tell me how can I do? thx

zheng@ubuntu:~/zcash$ ./qa/pull-tester/rpc-tests.sh
=== Running testscript wallet.py ===
Initializing test directory /tmp/test43eC_m
Mining blocks...
Stopping nodes
Cleaning up
Tests successful
--- Success: wallet.py ---

=== Running testscript listtransactions.py ===
: Error loading block database.

Do you want to rebuild the block database now?


#5

I didn't run any test after recompilation. Now I tried out and received the same message, but the miner works nevertheless. May be developers will explain.


#6
"version" : 110200,
"protocolversion" : 70002,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 0,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 0.00000000,
"testnet" : true,
"keypoololdest" : 1466257022,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,

#7

I am having a similar problem with connection. I deleted all old files and rebuilt z5 - but doess not work.
Please help.


#8

I just re-compiled and I'm up and running now. I seem to forget to re-create the zcash.conf file and that can cause a number of issues.

Is it possible that there was too much demand on alphatestnet.z.cash so soon after resetting?


#9

I deleted all old data of Zcash, and redo it. But still have an error like bellow:

zheng@ubuntu:~/zcash$ ~/zcash/./src/zcash-cli getinfo
{
"version" : 110200,
"protocolversion" : 70002,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 2195,
"timeoffset" : 0,
"connections" : 1,
"proxy" : "",
"difficulty" : 0.00000003,
"testnet" : true,
"keypoololdest" : 1466391557,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}


#10

That's not an actual error. It's just a warning that we didn't have enabled before (previous builds had the "is_release" flag incorrectly set to "true").