Can't sync with the message "You have validated 2240 transactions!"

Hi, Since I updated the fullnode to v5.2.0 it can not sync continue, please take a look the picture.
It pauses at 2240 transactions.
Please help me :frowning:
Thank you so much!
image

What are the specs on your machine? (Ram, cpu model, OS etc.)

Can you reliably reproduce the issue?
If so, please list the steps to reproduce below:
Git checkout v5.1.0/v5.2.0
./zcutil/clean.sh && ./zcutil/build.sh
./src/zcashd
Error message:
Message:
You have validated 2240 transactions!
Init message: Rescanning…
Segmentation fault (core dumped)

The version of Zcash you were using: v5.2.0
Machine specs:
OS: Ubuntu
CPU:
RAM: 15gb
Disk size: 243G
Disk Type (HD/SDD): SSD

Linux kernel version: Linux zcashfullnode 5.4.0-1034-gcp #37 SMP Wed Jan 6 19:44:48 UTC 2021 x86_64 x86_64x86_64 GNU/Linux

Compiler version (gcc --version):

gcc (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Linker version (ld -v): GNU ld (GNU Binutils for Ubuntu) 2.30

Assembler version (as --version):

GNU assembler (GNU Binutils for Ubuntu) 2.30
Copyright (C) 2018 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `x86_64-linux-gnu’.

We use google cloud!

This can happen if the zcash params get corruted and typically you just fetch them again or just reinstall the whole thing. Otherwise there are generalized steps to follow to clean up segfault conditions and the ‘logs’ application can display system log information specifically about why it crashed as can using some other commands. I had this occur as well (after Chilebob and others since) a few weeks ago with an OOM (out of memory) process killed but may be a different thing than yours. Also Id consider updating the distro. I liked 18 too! It did well but its the oldest, technically-still-supports distro as 16 went out not too terribly long ago.

It synced ok when I run with -reindex.
But it paused 95%

1 Like

Reindex helps clear most issues :+1:
Pausing at 95% may be due to the recent increase in tx’s and computational load. Does this node contain many addresses?

1 Like

99% when it’s done (100%) can we use as usual before? Or have to stop it and run another cmd again?

hic, it was killed :frowning:
[173974.857150] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/user.slice,task=zcashd,pid=19210,uid=1000
[173974.857200] Out of memory: Killed process 19210 (zcashd) total-vm:17562696kB, anon-rss:15847228kB, file-rss:0kB, shmem-rss:0kB, UID:1000 pgtables:31824kB oom_score_adj:0

The OOM issue is patt of the current focus of development. I think I read that increasing to 200GB of swap kind of worked for a little while but thats all I know

Now can not run @@
Messages:

  • Error: Error opening block database
    image

The OOM issue is known and has just been identified and fixed; it will be part of the upcoming 5.3.0 release. You can try building from the master branch of the repository if you need to run it sooner.

“Error opening block database” usually means that your block index is corrupted (which would make sense after crashing with an OOM). If you run your node with -debug you should see an error message in the debug.log with a more precise issue. The solution here is to restart with -reindex (but you’ll want to do this with a zcashd that has the OOM fix).

4 Likes

@str4d ETA?

1 Like

For those who know how to compile from source (should be everyone!) [verify, don’t trust!] I recommend this option. Managed to help my own issues and I have working full node again :zebra:

I also want to shout out to those who are working on these issues behind the scenes, thank you :hearts:

1 Like

Hi, lool like it’s done?
But can not get balance of an address (./src/zcash-cli z_getbalance zs1…m5), error message:
error code: -5
error message:
From address does not belong to this node.
How can fix? thanks

Use z_listaddresses to verify and also make sure the zaddy is “quoted”

the node is being run with cmd: ./src/zcashd -reindex -rescan
so is it possible that all z-addresses and the wallet have been removed?
Do I need to turn it off and just run the command: ./src/zcashd?

First Id check the syntax of the cmd unless you did double quote the zaddy and like I said you typically only call one or the other but otherwise yes now that its synced you should be able to stop and restart it without the rescan/reindex flags. Verify the address is in the node. If for some reason it isn’t then you’ll need to reimport the private key.