Can't upgrade zcash full node on ubuntu from 2.0.1 to 4.1.1

Every time I run zcashd I get this message:

$ Error: This version has been deprecated as of block height 476012. You should upgrade to the latest version of Zcash.

I understand that it’s deprecated and I need to update but when I try sudo apt update and sudo apt upgrade it shows that all packages are up to date.

The source list file has both:

Ign:7 https://apt.z.cash stretch InRelease
Hit:10 https://apt.z.cash stretch Release

What should I do?

It’s installed via the package manager not git.

Are you seeing any errors during the update (for example signing keys) see https://zcash.readthedocs.io/en/latest/rtd_pages/install_debian_bin_packages.html

1 Like

Thanks for your help, I got it solved through help from discord, turns out I had 2 versions installed.

2 Likes