Do any open source miners compile on Ubuntu Server 14.04?

I haven't been able to get any of the available miners to compile following the available documentation since yesterday.

Prior to yesterday I was able to get one of them to compile following the available documentation: https://github.com/ocminer/nheqminer.git. But checking today, it seems that one isn't compiling either.

Anyone have any luck getting these to compile? Double plus awesome points if you can tell me how to get one of the GPU miners up and running on Ubuntu Server 14.04.

I'm particularly interested in https://github.com/nicehash/nheqminer.git, but it fails on the command:

cd nheqminer/Linux_cmake/nheqminer_cuda_tromp && cmake . && make -j $(nproc)

Halp! :slight_smile:

Try changing the $(nproc) to your number of hyperthreads (either 4 or 8). For some reason that was previously giving me a problem. Nicehash's instructions worked for me on 40 desktops running Ubuntu 14 (not the server edition).

Hey, thanks for the reply. I gave that a shot. With or without $(nproc), the command results in a few pages of errors that ends with:

/usr/include/c++/4.8/cmath(443): error: variable "std::constexpr" has already been defined

/usr/include/c++/4.8/cmath(443): error: expected a ";"

Error limit reached.
100 errors detected in the compilation of "/tmp/tmpxft_0000254b_00000000-17_equi_miner.compute_61.cpp1.ii".
Compilation terminated.
CMake Error at nheqminer_cuda_tromp_generated_equi_miner.cu.o.cmake:264 (message):
  Error generating file
  /home/ubuntu/nheqminer/Linux_cmake/nheqminer_cuda_tromp/CMakeFiles/nheqminer_cuda_tromp.dir/__/__/cuda_tromp/./nheqminer_cuda_tromp_generated_equi_miner.cu.o


make[2]: *** [CMakeFiles/nheqminer_cuda_tromp.dir/__/__/cuda_tromp/./nheqminer_cuda_tromp_generated_equi_miner.cu.o] Error 1
make[1]: *** [CMakeFiles/nheqminer_cuda_tromp.dir/all] Error 2
make: *** [all] Error 2

I see they released 9 hours ago. My installs were v0.3a, not 0.4.

1 Like

And either them or sarah said the following was also needed, so my machines had it:

sudo apt install qt5-default

Here's my bash file to install the miner for CPU, use nanopool, and make aliases "start" and "stop" as the miner.

set -x

killall -9 nheqminer_cpu

rm -rf nheqminer

sudo apt-get update
sudo apt install qt5-default

# begin code exactly like nicehash install procedure 
sudo apt-get install cmake build-essential libboost-all-dev
git clone -b Linux https://github.com/nicehash/nheqminer.git
cd nheqminer/cpu_xenoncat/Linux/asm/
sh assemble.sh 
cd ../../../Linux_cmake/nheqminer_cpu 
threads=$(nproc)
cmake . 
make -j $threads
# end nicehash install

# begin defining aliases to start nanopool mining, no account with them needed
host=$(hostname)
taddr='[addr here]'
email='[email here]'
echo "alias start='~/nheqminer/Linux_cmake/nheqminer_cpu/nheqminer_cpu -l zec-us-east1.nanopool.org:6666 -u $taddr/$host/$email -p x -t $threads'" >> .bash_aliases
echo "alias stop='killall -9 nheqminer_cpu" >> .bash_aliases
bash exec

You may need 'bash exec' manually aftwards to activate the aliases.

1 Like

v0.4 installed and ran fine for me. Notice that I'm using xenoncat CPU linux install instructions instead of tromp. This is the first version they've had that gave tromp instructions, so I need to check its speed against the above xenoncat instructions.

I'll give that a shot tomorrow. Thank you. :slight_smile:

I run Saraths fork on Ubuntu 14.04 for CPU with this

sudo apt-get upgrade
sudo apt-get update
sudo apt install qt5-default
sudo apt-get install cmake build-essential libboost-all-dev
git clone https://github.com/sarath-hotspot/nheqminer.git
cd nheqminer/nheqminer
mkdir build
cd build
cmake ..
make

before running I use
screen -a
ctrl+a+d

./nheqminer -l zec-us-east1.nanopool.org:6666 -u taddress.work -t cputhreadsuwant2run

when closing putty this helps not shutting it done

Note: You might need to install git

1 Like