Error verifying joinsplit [Partially solved]

I’ve been using Zcash for a while but recently have run into a problem I’m unable to solve. When sending from a particular z-address using z_sendmany, z_getoperationresult reports the error:
runtime error: error verifying joinsplit
My debug.log doesn’t expand on the problem.

I’ve tried:

  1. different versions of zcashd (1.0.12, 1.0.13, and 1.0.14);
  2. disabling paymentdisclosure in zcash.conf;
  3. starting a new wallet before importing the key; and
  4. re-indexing.

The address has been involved in some large joinsplits such as transaction 1d667011135452e5ee25be023fccbc26c5df32fbe296798b13eb17f7078d61d1 (95 kB) and has built up a fair amount of history:

ZADDR=$(zcash-cli z_listaddresses | jq -r '.[0]')
zcash-cli z_listreceivedbyaddress $ZADDR | jq 'length'

I’m running Debian Stable and keep my system up-to-date:

uname -a
Linux host 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64 GNU/Linux

I tried booting with my previous kernel, 4.9.65-3+deb9u1, and discovered that I was able to send from the z-address in question. I’ve now processed 20 joinsplits without error.

It appears that the problem was being caused by Linux kernel 4.9.65-3+deb9u2. This was the update for Debian Stretch which patched the Meltdown vulnerability (CVE-2017-5754) (see the debian security announcement).