Ewbf-zcash on ethOS - help with reboot script if GPU fail

Hey all; one of my rigs likes to fail just after i go to sleep; but its not consistent; so i miss out on some mining while i sleep.

is there anything that i can add to the /etc/rc.local script to command a reboot if there’s a GPU failure?

i’ve got it setup that when it does reboot; it happily sets the power limits & OC settings.

i’m assuming i could (if i just wanted to set a reboot for every 8 hours), i could add

&& sleep 28800 && r

thank you in advance for your help.

1 Like

Hello, look at my script for Windows (CMD/BATCH) - if it is something like you search, I have some time and some BASH skill to try rewrite it for Linux too. Or ethOS it is not a Linux? :slight_smile: Need somewho with more Linux practice to help, and together we can do it!

Try to use --log 2 option and give me a .log file. Need to learn it…

I’m having a similar problem of a single GPU crashing and is unable to be restarted unless I restart the mining script (using minestop, minestart). It would be greatly appreciated if you could provide some help on a restart watchdog for ethOS, which is a 64-bit linux OS.

assuming you’re in ethos.

add autoreboot 3 to the config. (3 is max auto reboot)

also run a tail to find out what miner is crashing… and change your overclock settings.

I have autoreboot 3 in my config, it doesn’t restart the miner when one gpu
crashes. I’m running on default card settings, (no OC)