Guide to Mining on Unbuntu Headless Azure server

#1

Hey guys I would just like to say hello and ask, if anyone has seen a tutorial of guide for mining on a Ubuntu headless server. I have tried multiple times to set this up and can not figure this out. Does anyone have any links or suggestions?

Thanks in advance!

#2

sudo apt-get upgrade
sudo apt-get update
sudo apt install qt5-default
sudo apt-get install cmake build-essential libboost-all-dev
git clone https://github.com/sarath-hotspot/nheqminer.git
cd nheqminer/nheqminer
mkdir build
cd build
cmake ..
make

./nheqminer -l poolurl:port -u taddress.worker -t=numberofcputhreads

3 Likes
#3

Thank you for the quick reply,

When I try to run the sudo apt install qt5-default I get the following error:

Zec@ZecLin:~$ sudo apt install qt5-default
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 qt5-default : Depends: qtbase5-dev
               Depends: qtchooser but it is not going to be installed
 webmin : Depends: libnet-ssleay-perl but it is not going to be installed
          Depends: libauthen-pam-perl but it is not going to be installed
          Depends: libio-pty-perl but it is not going to be installed
          Depends: apt-show-versions but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I also try to install with apt-get -f install and the same error occurs any ideas?

#4

What version of Ubuntu are you running ?

1 Like
#5

Ubuntu 16.04.1 LTS

Should I downgrade to another version?

#6

I always use Ubuntu 14.04 (fresh install) and those commands work 100% of the time.

1 Like
#7

Ok I will delete that Vm and try a new one with that version of ubuntu and will let you know how it goes!

2 Likes
#8

Worked perfect! thanks for that!!!!

1 Like