Listsinceblock returns an empty array


I just installed zcash on an ubunta box. I set testnet in conf file and started zcashd. After a couple of hours, I can see it sync with the latest block from debug.log. When I run

zcash-cli getinfo
“version”: 4030050,
“build”: “v4.3.0”,
“subversion”: “/MagicBean:4.3.0/”,
“protocolversion”: 170013,
“walletversion”: 60000,
“balance”: 0.00000000,
“blocks”: 1318428,
“timeoffset”: 0,
“connections”: 8,
“proxy”: “”,
“difficulty”: 46.58371725767994,
“testnet”: true,
“keypoololdest”: 1615309233,
“keypoolsize”: 101,
“paytxfee”: 0.00000000,
“relayfee”: 0.00000100,
“errors”: “”,
“errorstimestamp”: 1615324792

However, when I run zcash-cli listsinceblock, I got
“transactions”: [
“lastblock”: “0016ac0b8ff69f3008a1f6033db988839acc56e0c508e376f5ba403337416d7f”

I run the same command on another box which has zcash installed before, I can get some transactions. Does anyone know why I get an empty transaction array? Is there any configuration parmater I missed? I do see I have blocks under testnet3 directory.


listsinceblock returns transactions specific to your wallet, so if you have not yet sent funds from or received funds to an address in your local testnet wallet, the array will be empty.

Thank you. From the documentation,

listsinceblock ( “blockhash” target-confirmations includeWatchonly)

Get all transactions in blocks since block [blockhash], or all transactions if omitted.

so I thought I can use it to grab the transactions from blockchain. Do I misunderstand the documentation?

I also tried something like “zcash-cli listsinceblock “000000000000000bacf66f7497b7dc45ef753ee9a7d38571037cdb1a57f663ad” 6”

but still get an empty array. so what is the coomand I can use to get transactions from blocktrain