./qa/zcash/full-test-suite.sh - Failed Test

I'm getting an error when running the full-test-suite.sh.

Not only that but my computer becomes completely unresponsive. I waited a few hours when it was unresponsive the first time I tried running the full test, then decided hard shut down my computer. Restarted computer. Made sure everything except terminal was closed. Restarted test. It became completely unresponsive again, although it did make some progress after it had become completely unresponsive. It is still completely unresponsive again, and has failed the most recent test. It has been about 3 hours. The error is as follows:

    (more unnecessary output above)
    make[4]: Entering directory ' /home/anton/zcash/src'
    ../build-aux/test-driver: line 107: 26637 Killed                                                            "$0 > $log_file 2>&1
    FAIL: test/test_bitcoin

Does anybody have any idea what's going on?
How long should that test take?
What does the failure mean?

Thanks

I have the same error but befoe I have
zcash-cli: failed NXRELRO
zcash-tx: failed .............
makefile:7989 : la recette pour la cible "check-security" a echoué (I'm in french, means check for "check-security" failed)

the reason i was getting that error, i believe, was because a lack of RAM. i only had 4gb of ram, and the OS took up 1gb. so maybe that's your issue too?? hm... that's a pretty sketchy message. you sure your copy is legit? you cloned it from github?

I have 16 gig, 8 for my OSX and 8 on a virtual machine for the last Ubuntu, i clone it from github (I did not copy all the message, .... means other errors)

I have also 3 errors with the rpc test. But i can complete this test, not the test-suite

Tests completed: 21
successes 18; failures: 3

Failing tests: wallet_protectcoinbase.py wallet.py wallet_nullifiers.py

hm... i was able to pass the full-suite-test when i hooked the HD up to my main system. however, my main system even got hung up on the rpc-tests for whatever reason. i got 8gb of much better ram on this thing too.

to be honest, i have no idea what might be causing you those issues. all i can think of is to make sure your ubuntu is up-to-date!! sorry

did you verify ur zcash after downloading it? it sounds like it might be corrupted

I have the last version of Ubuntu. I'm going to update my ram... thanks. I think the zcash is not corrupted I've just cloned another one always on a virtual machine, but on a pc system, with the same Ubuntu, the last one, I have the same errors.

try using a diff linux distro. i'm using elementary os. 8GB should be more than enough!!

Maybe I have the solution, in the vm settings i've only put 1 processor, i've passed this parameter to 4 and the wallet' tests are OK: Success: wallet_protectcoinbase.py.,Success: wallet_nullifiers.py
, Success: wallet.py. And i think you're right 8 gig is enougth. Thanks

oh man, you got it! there you go. yeah, i'm not using a VM. i'm just dual booting sooo

Are you CPU or GPU mining ? Is so important for zcash ?

Well, apparently you can do both, so that's what I want to do. The more computing power the merrier :slight_smile: You can stack GPUs a lot easier than CPUs, so I think that's why a lot of people are choosing to mine only with GPU; and this way they can probably also still use their computer while it's mining

Ah... It's always not good for the full-test-suite.sh.

I'm going to try a double boot. Thank's for the answers

have you tried mining yet? or just the tests?