Unmet dependencies libc6-dev

This is the dockerfile/repo DAppNodePackage-zcash/Dockerfile at master · dappnode/DAppNodePackage-zcash · GitHub

The upstream version variable value is v4.6.0+2

The following packages have unmet dependencies:
 zcash : Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is to be installed
E: Unable to correct problems, you have held broken packages.

I have tried to install libc6 but it does not solve this issue. Some idea how to fix it?

You will likely want to update that stretch resource in the linked dockerfile to buster or bullseye. We no longer support Stretch due to upcoming EOS and focus on other platforms.

See Update Dockerfile by mdr0id · Pull Request #5828 · zcash/zcash · GitHub

1 Like

I have solved the problem using buster-slim as docker image instead. Thanks for the answer!

Nice! If you run into any other snags/issues please let us know.