Unmet dependencies- libgomp1 and libstdc++6

Installing Zcash on Linux Mint 17.3 - running into an issue. Can someone suggest how to troubleshoot/fix?

user@user-VAW70 ~ $ sudo apt-get install zcash
[sudo] password for user:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zcash : Depends: libgomp1 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is to be installed
Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.
user@user-VAW70 ~ $ zcash-fetch-params
zcash-fetch-params: command not found
user@user-VAW70 ~ $

I ran into several issues trying to install on Mint, since switching to Ubuntu I have not had any more compatibility errors. Your best bet is going to be Ubuntu, Lubuntu or Debian

you need to install libgomp1, but you don't have a C++ standard library that's new enough: it needs at least gcc 4.9, and your version of Mint is using the standard library from gcc 4.8.

Does a newer version of Mint ship with gcc 4.9? if so, upgrading to that would let you install the binary deb of zcash. If not, does your release of mint have gcc 5.x or 6.x available for it? If so, you could build it from source yourself with a newer compiler.

@anon47418038 is correct that you need to install gcc/g++ 4.9 or later. Linux Mint may be sufficiently close to Ubuntu that the instructions for upgrading gcc on Ubuntu in the 1.0 User Guide will work. (Note to others: only try this for the Ubuntu-based distribution of Mint, not for LMDE.)