Zcash Pool Zmine CLOSING

Works good, no issues. One thing perhaps; you could raise diff to be 1 or even more?

And perhaps adding instructions how to mine using NiceHash? Thanks.

The difficulty is set at 1 which is the same as the genesis block.
That means 1/16 should match the difficulty.

I will look into it.

The difficulty of one for zcash is not 0x0fffffff but 0x0f0f0f0f, that is why your pool actually has diff of 0.94117600.

I was a bit too fast saying that everything works fine. Occasionally pool drops connection. Any reason for that?

I saw in the logs that some submits had invalid json.
It will drop the connection for a minute when that happens.
Unfortunately I can't investigate it right now.
Maybe 2 submits got mixed together?

We did packet sniff and found nothing strange coming from our side (all messages were correct JSON format, valid shares). After certain share, your pool simply sent back FIN packet. You should probably investigate this issue on your side.

Have you had anyone set up mining on AWS using the pool? Would love to test it out

@simonburns I tried on Google cloud.
It worked and able to generate blocks.

I was using google cloud because for 2 CPU/7.5gb machine Google is cheaper than AWS.
In my test run I could mine 30 blocks in 12 hours.

it works and I'm mining.

Mining for a couple of hours, but somehow the rewards from the rounds is different to the calculated total reward. And I havn't seen a payout yet..
http://zmine.io/workers/tmBGN8G87k9DPMDDcRgqmyNA5cKWgVeLfVX

The reward only gets added to your total after 100 confirmations.
That is how long it takes before Zcash allows you to send new coins.
I am going to add this so you can clearly see how much of your reward is already confirmed and how much is pending.

I would suggest you to use this miner:
https://github.com/sarath-hotspot/zcash/tree/standalone-miner
It's a lot faster then the one made by Str4d.

@razakal thanks for the explanation. I'll try out the miner you mentioned. Currently my 4770k is running pretty hot for ~0.1H/s

Run @sarath-hotspot's standalone miner with generic limit as 8. You will definitely see 10sol/sec.

Wow, thanks @sarath-hotspot 100-fold increase with your miner!

it is not my miner. @tromp is author of optimised solver and I just integrated with standalone miner.

1 Like

How do we install it?

https://github.com/sarath-hotspot/zcash/wiki

2 Likes

Thank you very much !!!

I installed this miner without issue and am now mining on zmine.io. I did try to run the zminer earlier and kept getting "Permission Denied" when starting that miner. So I have no way to know if this hashes any faster or not. I did not remove the zminer directory etc., so I compiled a new miner directory and called it sminer.
My avg hash is somewhere around .30 h/s mining @ 2 hours, 19 blocks, total shares 217.
Mining on AMD Phenom 1100t , 5Gb ram dedicated to Virtual Box in which I am running Ubuntu on W7. ok :slight_smile:

Edit: that's .30 h/s sorry I had forgot the decimal, was late sorry lol

I ran and compliled @sarath-hotspot code for the standalone miner against the pool with an old i3 last night, and got a payout of nearly half the block later.

Definitely taking advantage of @tromp optimisations, as there were several other active miners according to the pool information.

Was there a technical issue with the pool last night, out of interest? No blocks mined for many hours, after being a couple times an hour at least. Got paid in bulk for a lot of shares later on when the next block came in...

Wow you are getting 6 Sol/sec/core.. this is optimal performance.

How are you verifying your hash rate? In some page?