Zcashd sendmany t to t address


#1

I installed new zcashd, enabled testnet, txindex, let it download chain
I went to https://faucet.testnet.z.cash/ got 3 ZEC confirmed in my wallet
I generated fresh address using rpc
I tried to send some coins to that address:
zcash-cli sendtoaddress tmXLVS17VJRLHjjH3UjUt1kfFeDJQAPmb3x 0.123 "cdvd"
but got
error code: -4 error message: Error: The transaction was rejected! This might happen if some of the coins in your wallet were already spent, such as if you used a copy of wallet.dat and coins were spent in the copy but not marked as spent here.
I’m surre this is not the case

same procedure works fine with bitcoind

what is it I’m doing wrong here ?


#2

https://zcash.readthedocs.io/en/latest/rtd_pages/payment_api.html#z-sendmany


#3

Are you trying to say I should use sendmany instead of sendtoaddress ? Otherwice I want to add that I don’t spen coinbase, I got coins from faucet in transparent transaction.

I tried sendmany, which worked for me, but it needs from address specified, but most of the time I need to send coins from more addresses, I think lates bitcoind don’t have this limitation


#4

With sendmany you specify "" as the first argument to use available funds see https://zcash-rpc.github.io/sendmany.html

I just tried sendtoaddress and it works as it should. Was your node fully synced when sending?