7x rx 480 ubuntu 16.04 problem

so i received some new risers today and installed gpu 6 and 7.
On boot i get low graphics error, so i check the log and amdgpu-pro detects all 7 gpu.
However there is a error in the log
"
Segmentation fault at address 0x0
Caught Signal 11(segmentation fault), Server aborting
"
So i tried a few things that i found online including a fresh install of ubuntu

fresh install ubuntu
amdgpu-pro driver install
reboot
error: low graphic

any ideas what i can do about this

That's a null pointer dereference (i.e. bug). The quote doesn't tell which process crashed but presumably it is the X server. Look through dmesg and /var/log/Xorg.0.log to see if there's anything useful just before the segfault. Also, if you haven't done it already, remove all GPUs and add them back in one at a time to see if a specific one of them triggers the problem, or if it is always the 7th card to be added that kills it.

i had 5 cards running without issues, adding card 6 and 7 produces the problem
i can ad any card up to 5 cards in random slots with or without risers(3 cards on board and 2 risers) and the system runs flawless
adding a 6th card to the system produces the problem
power shouldn't be the problem evga 1600 T2
MSI z97 gaming 5 board with intel i3 cpu and 16 gig ram

i did choose that board as someone else has the same board and at least 6 cards running

u can login with ssh. just kick the miner.

ok so general question
if i just install ubuntu or debian, do i still need to install the amdgpu-pro driver if i start the miner without the gui?

yes, you need it. you don't need gui.
instruction here

i am not to familiar with linux but as i understand it, that error has to do with the gui
could you point me how to start ubuntu on boot without the gui

  1. install ubuntu with less 5 GPUs
  2. check the instruction here to all setup
    https://forum.zcashcommunity.com/t/silentarmy-v5-115-sol-s-on-r9-nano-70-sol-s-on-gtx-1070/3580/359
  3. install openssh
    $sudo apt-get install openssh-server
  4. install ssh client to your other PC or MAC
  5. access via ssh, login, kick the miner

sudo apt-get remove lightdm
and i get to boot without gui

without gui optiminer works on all 7 rx480
but i think with low sol for 7 cards (~780sol)
i will wait a bit to see if it goes up

u don need uninstall gui.
anyways happy mining!!

:slight_smile: thanks for the help

i think the miner is dropping a gpu
might be a faulty gpu or again a riser defective
back to square 1

Those who have the problem, you use the video gpu integrated in the motherboard?

well after almost 2 days testing i got a hint (thanks cryptomined) that the bios could have reset itself and sure enough it had
setting back to gen2 / 8x4x4x and the system is running fine with all 7 cards working
still can't get into the gui but i don't need the gui so all good
happy now lol

Topic was solved, future posts should be in AMD Thread