Almost there ! CPU Dual Xeon Test


#1

I'm running a test via Windows 10 Bash. I will write up a tutorial post when I succeed.

I'm at running this (./src/zcashd -daemon), but I get this :

root@PRECISION:~/zcash# ./src/zcashd -daemon
Zcash server starting
root@PRECISION:~/zcash# Error: To use bitcoind, or the -server option to bitcoin-qt, you must set an rpcpassword in the configuration file:
/root/.zcash/zcash.conf
It is recommended you use the following random password:
rpcuser=bitcoinrpc
rpcpassword=7y624eKZyhjENndmEZ52QuaQKWg6MsenmYhfsuJKdGRY
(you do not need to remember this password)
The username and password MUST NOT be the same.
If the file does not exist, create it with owner-readable-only file permissions.
It is also recommended to set alertnotify so you are notified of problems;
for example: alertnotify=echo %s | mail -s "Bitcoin Alert" admin@foo.com

This is my zcash.conf :

testnet=1
addnode=betatestnet.z.cash
rpcuser=bitcoinrpc
rpcpassword=4hiZX4reHpMQNKXuSsTXRREjYPQkCFZCQY9m82C6eNzj

This is located here : \root\.zcash

This windows just stays there ... (http://prntscr.com/cszo3s)

What's the next step ?

If I run ./src/zcash-cli getinfo I get this :

error: You must set rpcpassword=<password> in the configuration file:
/root/.zcash/zcash.conf
If the file does not exist, create it with owner-readable-only file permissions.

The file is there : http://prntscr.com/cszow3

The directory structure seems to be fine : http://prntscr.com/cszp74

Any idea ?


#2

Ok, so I tried this

$ ./src/zcashd -daemon -debug -printtoconsole

And I got this :

Zcash server starting
root@PRECISION:~/zcash#



















Bitcoin version v1.0.0-beta2 (2016-10-04 21:55:26 -0500)
Using OpenSSL version OpenSSL 1.1.0b  26 Sep 2016
Using BerkeleyDB version Berkeley DB 5.3.28: (September  9, 2013)
Default data directory /root/.zcash
Using data directory /root/.zcash
Using config file /root/.zcash/zcash.conf
Using at most 125 connections (2048 file descriptors available)
Using 16 threads for script verification
Loading verifying key from /root/.zcash-params/beta2-verifying.key
scheduler thread start
Loaded verifying key in 0.003006s seconds.
Allowing RPC connections from: 127.0.0.0/255.0.0.0 ::1/ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
Error: To use bitcoind, or the -server option to bitcoin-qt, you must set an rpcpassword in the configuration file:
/root/.zcash/zcash.conf
It is recommended you use the following random password:
rpcuser=bitcoinrpc
rpcpassword=2UmoFBkWKg3G15mzrg1MjdjDoZvbezYP9b1d9Nttxx4K
(you do not need to remember this password)
The username and password MUST NOT be the same.
If the file does not exist, create it with owner-readable-only file permissions.
It is also recommended to set alertnotify so you are notified of problems;
for example: alertnotify=echo %s | mail -s "Bitcoin Alert" admin@foo.com

Using wallet wallet.dat
init message: Verifying wallet...
CDBEnv::Open: LogDir=/root/.zcash/database ErrorFile=/root/.zcash/db.log
Bound to [::]:8233
Unable to bind to 0.0.0.0:8233 on this computer. Bitcoin Core is probably already running.
Cache configuration:
* Using 2.0MiB for block index database
* Using 32.5MiB for chain state database
* Using 65.5MiB for in-memory UTXO set
init message: Loading block index...
Opening LevelDB in /root/.zcash/blocks/index
Opened LevelDB successfully
Opening LevelDB in /root/.zcash/chainstate
Opened LevelDB successfully
LoadBlockIndexDB: last block file = 0
LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=1, size=1700, heights=0...0, time=2009-01-03...2009-01-03)
Checking all blk files are present...
LoadBlockIndexDB: transaction index disabled
LoadBlockIndexDB: hashBestChain=027e3758c3a65b12aa1046462b486d0a63bfa1beae327897f56c5cfb7daaae71 height=0 date=2009-01-03 18:15:05 progress=1.000000
init message: Verifying blocks...
Shutdown requested. Exiting.
Shutdown: In progress...
scheduler thread interrupt
StopNode()
Committing 0 changed transactions (out of 0) to coin database...
Shutdown: done

#3

Could it be related to any wallet already running (Bitcoin, Litecoin, Peercoin ?


#4

Did you build zcashd in the Bash On Ubuntu On Windows subsystem, or natively with something like mys2?

I'm curious because I've been working on an msys2/mingw64 build.

Thanks!


#5

I did it on Bash On Ubuntu On Windows subsystem


#6

very possibly, BTC and zcash use the same rpc ports, but zcash is still on a testnet, which has different ports than a production bitcoin installation. I wouldn't run zcash on the same box that has another wallet on it, that...could be bad.


#7

nah, atm the testnet's definitely localhost:18232, can talk to it with json::rpc
u hafta open firwall ports ...
I did these for ubuntu:
ufw allow out 18232/tcp
ufw allow in 18232/tcp
ufw allow out 18233/tcp
ufw allow in 18233/tcp
ufw status


#8

I found the problem, you cannot create the .conf file via windows, ubuntu won't recognize it. Instead I edited a .log file and with the conf info and renamed it in the console. It worked !

... got a 0.06 hashrate with dual xeon ...