ASROCK H81 PRO BTC R2.0 PCIE slots do not detect GPU

I bought two ASROCK H81 PRO BTC R2.0 motherboards, and they're both presenting the same problem: PCIe slots do not recognize the GPU (regardless of the GPU or the PCIe slot used).
The cards fail to be detected even if I try to install them directly onto the 16x slot without a riser. I'm pretty sure the problem is not the GPUs because I have them running fine in other systems. The problem is present as early as startup, at BIOS, so before the OS (in this case Linux) is even loaded. The system starts up with the integrated graphics only, as if there was no GPU connected. I have made sure the usual options in the BIOS were selected as I've done before with several machines: PCI Adapter as primary graphics etc. but unfortunately this did not solve the problem.
Tried to contact ASROCK support, have not heard anything from them after 5 days.

I'm wondering if anyone is using the same motherboard with Linux (even though I don't think it's an OS problem) successfully.

Maybe it is not the problem but.
-Did you connect 2 x molex 4 pin cable to MOBO? For Asrock Mobo it is needed.
-Did you set up initial GPU at bios?

Problem was solved. I disconnected the motherboard. Reset cmos and battert. Tried with another GpU was able to get display in the end.