Debian binary update issue

~$ sudo apt-get update && sudo apt-get install zcash
Hit:1 http://au.archive.ubuntu.com/ubuntu zesty InRelease
Hit:2 http://au.archive.ubuntu.com/ubuntu zesty-updates InRelease
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:4 http://au.archive.ubuntu.com/ubuntu zesty-backports InRelease
Hit:5 http://security.ubuntu.com/ubuntu zesty-security InRelease
Ign:6 https://apt.z.cash jessie InRelease
Hit:7 http://dl.google.com/linux/chrome/deb stable Release
Get:10 https://apt.z.cash jessie Release.gpg [819 B]
Err:10 https://apt.z.cash jessie Release.gpg
The following signatures were invalid: F1E214037E94E950BA8577B263C4A2169C1B2FA2
Fetched 819 B in 1s (565 B/s)
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://apt.z.cash jessie Release: The following signatures were invalid: F1E214037E94E950BA8577B263C4A2169C1B2FA2
W: Failed to fetch https://apt.z.cash/dists/jessie/Release.gpg The following signatures were invalid: F1E214037E94E950BA8577B263C4A2169C1B2FA2
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
zcash is already the newest version (1.0.9).
The following packages were automatically installed and are no longer required:
libpango1.0-0 linux-headers-4.10.0-19 linux-headers-4.10.0-19-generic
linux-headers-4.10.0-20 linux-headers-4.10.0-20-generic
linux-headers-4.10.0-21 linux-headers-4.10.0-21-generic
linux-image-4.10.0-19-generic linux-image-4.10.0-20-generic
linux-image-4.10.0-21-generic linux-image-extra-4.10.0-19-generic
linux-image-extra-4.10.0-20-generic linux-image-extra-4.10.0-21-generic
linux-signed-image-4.10.0-19-generic linux-signed-image-4.10.0-20-generic
linux-signed-image-4.10.0-21-generic
Use 'sudo apt autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 14 not to upgrade.

1 Like

In addition to the problem with the Debian signed packages encountered here, there is another bug in 1.0.10 that causes it to fail to connect to other nodes. So, we recommend that users stick with 1.0.9 for now, and then upgrade to 1.0.10-1, which will also fix the package signature problem, when it is released.

1 Like

Zcash 1.0.10-1 has been released. https://z.cash/blog/new-release-1-0-10-1.html

2 Likes

I upgraded my Debian to Stretch (Debian 9) with a new fresh install from dvd.
When I tried to install zcash using the info from https://github.com/zcash/zcash/wiki/Debian-binary-packages it failed when installing "apt-get install zcash"

Err:6 https://apt.z.cash jessie InRelease                                     
  Connection timed out after 120000 milliseconds
Leyendo lista de paquetes... Hecho
W: Fallo al obtener https://apt.z.cash/dists/jessie/InRelease  Connection timed out after 120000 milliseconds

To solve this problem I downloaded the zcash-1.0.10-1-amd64.deb package directly from
https://apt.z.cash/pool/main/z/zcash/

it works. But I have no idea why it failed.

1 Like