Error compiling eXtremal-ik7/xpmclient version/zcash branch - open CL problem with ARMv7 & Mali OpenCL SDK v1.1

hello everyone,
trying to compile the eXtremal-ik7 client on an ARMv7 powered board I'm having problems with a open CL constant:

/zcash/zcash-xpmclient/opencl.h:78:17: error: ‘CL_MEM_HOST_NO_ACCESS’ was not declared in this scope
 if (flags & CL_MEM_HOST_NO_ACCESS)
                 ^
CMakeFiles/xpmclient.dir/build.make:166: recipe for target 'CMakeFiles/xpmclient.dir/primes.cpp.o' failed

Has anyone experienced the same and happens to have found a solution to this ? Maybe not only with extremal's code but with OpenCL on ubuntu-mate powered boards ? It's the first time I download the Mali Open CL sdk so I may be missing something, the libOpenCL.so is available. Here is my cmake configuration command :

$ cmake . -DOPENCL_LIBRARY=/usr/lib/arm-linux-gnueabihf/libOpenCL.so -DOPENCL_INCLUDE_DIRECTORY=/opt/mining/mali-opencl-sdk/Mali_OpenCL_SDK_v1.1.0/include
$ make -j$(nproc)

Any help is appreciated here!

Thank you all!

1 Like

What board? I'm quite familiar with many of them.

I tried using a Raspberry Pi 3 but also a Odroid XU4 - i tried once with raspbian image, once with ubuntu mate

1 Like

How about the build environment?

FYI I'm 0-3:

  • OrangePI PC
  • BananaPi M3
  • Geekbox/Cross

Re-reading, maybe you need to declare that variable? But you said it was a constant. So maybe you don't/cant'. I';m speaking of course of CL_MEM_HOST_NO_ACCESS. And looking at what you pasted, my solution is likely invalid. This is going to take the wizard of MALI.

well the boards installation are kept pretty simple, firewall install etc.. account deletion/creation.. then i followed the build instructions found here:

When you mean, you are 0-3, does it mean you couldn't configure it on those 3 boards either? :stuck_out_tongue:

Thanks mate!

Ah, yes that is my meaning exactly.

I'm happy to keep pushing at this with you though. those ARM boards represent so many tiny, cheap GPUs!

exactly! i own 2 raspberry pi 3 and an odroid xu4 which i wanted to test mining with. Mining zcash with my PC/laptop is no problem.. only ARM seems to be lost

I must say that mining ZCoin is ok with those though, but ZCoin is a complete other topic, and works only with one given cpu miner--