Error Running Daemon - No Such File Or Directory

Hi,

I've followed 2 different step by step guides to start mining on the zcash testnet but I keep running into the same roadblock.

Using Ubuntu in virtual box on Windows 10.

The Guides I Followed:
- https://www.cryptocompare.com/mining/guides/how-to-mine-zcash
- https://github.com/Austin-Williams/zcash-guides/wiki/Guide-to-Solo-Mining-Zcash

When I run the command ./qa/zcash/full-test-suite.sh everything that should happen does until the last line where it gives this error:

configure: error: libdb_cxx headers missing, Bitcoin Core requires this library for wallet functionality (--disable-wallet to disable wallet functionality)

When I run the next step ./qa/zcash/full-test-suite.sh I get the following errors:

===== BEGIN: /home/rivercityjon/zcash/qa/zcash/check-security-hardening.sh
make: Entering directory '/home/rivercityjon/zcash/src'
make: *** No rule to make target 'check-security'.  Stop.
make: Leaving directory '/home/rivercityjon/zcash/src'
===== FAILED: /home/rivercityjon/zcash/qa/zcash/check-security-hardening.sh
===== BEGIN: /home/rivercityjon/zcash/qa/zcash/ensure-no-dot-so-in-depends.py
arch-specific build dir not present: /home/rivercityjon/zcash/qa/zcash/../../depends/x86_64-unknown-linux-gnu
Did you build the ./depends tree?
Are you on a currently unsupported architecture?
FAIL.
===== FAILED: /home/rivercityjon/zcash/qa/zcash/ensure-no-dot-so-in-depends.py
===== BEGIN: make check || { echo === ./src/test-suite.log === ; cat ./src/test-suite.log ; false ; }
make: *** No rule to make target 'check'.  Stop.
=== ./src/test-suite.log ===
cat: ./src/test-suite.log: No such file or directory
===== FAILED: make check || { echo === ./src/test-suite.log === ; cat ./src/test-suite.log ; false ; }

And the next step of course also had errors

./qa/pull-tester/rpc-tests.sh
./qa/pull-tester/rpc-tests.sh: line 6: /home/rivercityjon/zcash/qa/pull-tester/tests-config.sh: No such file or directory

Finally getting to the Daemon of course nothing changed.

~/zcash/./src/zcashd -daemon
bash: /home/rivercityjon/zcash/./src/zcashd: No such file or directory

Obviously the recurring theme is missing file or directory, but what am I actually missing? I've gone through each tutorial 3 times step by step on a fresh install of ubuntu and have run into the same roadblock each time.

Hello rivercityjon,

I followed this beautiful guide at a VM with Debian 8.5.0 64bits and it works very well,
the guide I followed is this page:

https://github.com/zcash/zcash/wiki/Beta-Guide

I hope you get that you need. Thank you a lot.

I'm in the same boat and can't find why this is happening

Use 64 bit/ linuxmint/ ubunto..No Such File Or Directory.... debian error r13 error.. Heelpp need a key Miner eating dust... http://askubuntu.com/questions/133389/no-such-file-or-directory-but-the-file-exists install amd update.. no idea to fix. sudo issue? root instal?

Assuming that you are following the latest guide here:

Please make sure that the previous step (BUILD) completes without errors:
./zcutil/build.sh -j$(nproc)

Since the build is a very long process, you may want to output it to a text file and search for errors. I had the same problem but ensuring that the build was successful allowed the test to be successful also.