Getting 'no such file or directory' when trying to run server


#1

I have tried a whole new setup and build, twice actually, and have made sure not to miss any steps, have all params, set up conf file, even tried the 32/64 bit fix with 'sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386' in case i was missing something..and throughout the downloads and build, it was quite happy - but when i go to run the server at ./src/zcashd -daemon, i get 'no such file or directory' - what am i missing? I've tried every syntax i can think of..


#2

~/zcash/./src/zcashd -daemon


#3

Thx..but i had tried that already....along with every other permutation imaginable..i've got something wrong somewhere else methinks.

i saved the conf file in the .zcash folder i created (file inside has appropriately been named zcash.conf, and has all the right parameters..I saved the .zcash folder within zcash - that ok? can it be anywhere? ill try moving to different locations. i've run out of ideas though. Trying to run from Canada, that a problem serverwise?


#4

I'm in the same boat !

I tried both :

./src/zcashd -daemon
~/zcash/./src/zcashd -daemon

no luck !


#5

I haven't figured it out yet, but when i started over, i found that not all the dependencies downloaded properly. I believe the problem is there rather than in the command to connect to the server. Good luck. let me know if you find anything?


#6

Actually, I had your setup ... I got much more success on doing this via Bash on Windows 10, if you can, works much better than running this on virtualbox ...


#7

I tried running :

$ ./src/zcashd -daemon -reindex

instead of ;

$ ./src/zcashd -daemon

and it seems to have worked even though I wasn't upgrading. Not sure why as it just restarts the node but seems to solve wallet issues as well.

"If you are encountering problems with the wallet, try stopping and restarting your node with the -reindex flag, as in the following command: $ ./src/zcashd -reindex "

Hope that helps.