Getting started - issues


#1

Just going to throw this out first - This is my first venture into cryptocurrencies and I'm also a lowly-skilled with Linux in general. So if something I toss-out, ask, say, is very obvious to the rest of you, you have been warned :slightly_smiling:

So, I've been following directions from the 'Where do I begin' site with the last successful step being completed being to create the file "bitcoin.conf" in the /zcash/ directory using the given variables.

The next step - the one which I'm stuck on - is "Now, run the daemon!". So in my terminal I plug in "./src/zcashd -daemon" and I get hit with "No such file or directory"... Next I tried "cd /root/zcash/src/" and ran the command again. Same error. Then I tried running just "zcashd - daemon" and I was given the error "Command not found". So at this point I don't know what to do... Please advise?

*I've ran into this issue twice. I did this all once on Ubuntu, then I tried it again on Kali - same exact errors and issue. So I feel safe that the download and build completed successfully..


#2

Familiarity with Bitcoin's build procedures is very helpful for using zcash!

You must use Linux and you must compile the project from source via ./zcutil/build.sh. See the top of the guide for more details on that.


#3

Have you had any build errors? If so check you have all the required dependencies installed

sudo apt-get install build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev bsdmainutils

@ebfull provided these on Github

Install these and try the build process again


#4

@ebfull Oh I'm sure it is! So yes, I am using Linux - two different flavors just because: Kali and Ubuntu. And yes, I got past building and compiling. Thanks.


#5

@squawka I didn't see any during the process - so I am going to guess not. Also, all the files, folders, and directories are present and it looks like everything is there - just missing "zcashd" - whatever that is...

I'll check out what you just referenced and then install and then build again. Thank you!


#6

@squawka I followed your instructions - thank you for those by the way. So after going through the build process again (did not see any errors), I ran the command "./src/zcashd -daemon" and now I see this;


EXCEPTION: St13runtime_error
Could not open proving key file: /root/.zcash-params/zc-testnet-public-alpha-proving.key
Please refer to user documentation for installing this file.
bitcoin in AppInit()

I'm going to refer to the documentation as suggested. Just thought I'd put this in here in the mean time!


#7

@g3s17h87 in IRC the following was mentioned

earthrise: proving key's uploading to s3

So I am guessing they're being uploaded again or you haven't ran

./zcutil/fetch-params.sh


#8

Ran that - still get the same error previously mentioned... Haven't found a solution just yet either via documentaiton, if not evident...
Thank you for that though! You know your ish on this :slight_smile:


#9

@g3s17h87 I would expect the documentation to be pretty thin right now, join the IRC channel if you haven't already and others experiencing the same issue and for possible fixes.


#10

Hey, honestly you are way ahead of me. I am trying to get into cryptocurrencies but I do not understand how am I suppose to even begin. I do not have linux installed on my computer and I do not know how to run even in the first step. Is it too much to ask for your help? XD


#11

@ChrisdahFur install a Linux OS in a VM and have a play around to get familiar with using Linux (You won't look back when you get the hang of it) I wish I had the time available to help you more


#12

That's alright, I understand, I figured I had to install linux. Ima go ahead and do that. Is it basically just running terminal on linux and running the commands on the guide?


#13

@g3s17h87 do you also have a mac?


#14

@ChrisdahFur yes follow the instructions in terminal just remember to install the dependencies which are listed on this thread


#15

I got following error while trying to compile, on a VPS running Ubuntu 14.04:

cd /home/xxxxx/zcash/depends/work/build/x86_64-unknown-linux-gnu/crypto++/5.6.2-87fe5822d38; unzip /home/xxxxx/zcash/depends/sources/cryptopp562.zip
/bin/sh: 1: unzip: not found
make: *** [/home/xxxxx/zcash/depends/work/build/x86_64-unknown-linux-gnu/crypto++/5.6.2-87fe5822d38/.stamp_extracted] Error 127
make: Leaving directory '/home/xxxxx/zcash/depends'

I installed all dependencies provided above. What am i missing ?


#16

You do not have unzip installed

sudo apt-get install unzip


#17

How do i see the balance and unspent outputs of the "protected" Zcash ? Apparently listunspent and getbalance does not give those information. Does this mean i need to save those encrypted buckets to a text file every time i perform a zcrawreceive or zcrawpour transaction ?

What can i do in case i forget the zcsecretkey ? the command dumpprivkey only works for bitcoin addresses.


#18

These RPC commands are "raw" in that they allow you to interact directly with the scheme.

The wallet is not implemented yet, but when it is, not only will you be able to see a balance/unspent coins as you suggest, but also you will not need to transfer encryptedbucket1 or encryptedbucket2 over an outside channel, as this is sent over the blockchain in a memo field.


#19

from guide: https://github.com/Electric-Coin-Company/zcash/wiki/Public-Alpha-Guide

First install the dependencies:
sudo apt-get install \
build-essential pkg-config libgtest-dev libc6-dev m4 \
g++-multilib autoconf libtool ncurses-dev unzip git python \
zlib1g-dev wget bsdmainutils

unresolved dependencies:
g++-multilib : Hängt ab von: cpp (>= 4:4.9.1-4ubuntu2~ubuntu14.04.1~c42.ppa1) aber 4:4.8.2-1ubuntu6 soll installiert werden
Hängt ab von: gcc-multilib (>= 4:4.9.1-4ubuntu2~ubuntu14.04.1~c42.ppa1) soll aber nicht installiert werden
Hängt ab von: g++ (>= 4:4.9.1-4ubuntu2~ubuntu14.04.1~c42.ppa1) soll aber nicht installiert werden
Hängt ab von: g++-4.9-multilib (>= 4.6.4-1~) soll aber nicht installiert werden

...and I am stuck.
What to do?


#20

@casch maybe this can help;

http://ubuntuforums.org/archive/index.php/t-2202151.html