Installation with apt-get does not work

Hi I tried to use apt-get to install the package on Linux Mint (which is a Ubuntu based distro) but I am getting this error:
W: Failed to fetch https://apt.z.cash/dists/jessie/main/binary-amd64/Packages gnutls_handshake() failed: Handshake failed

Any idea what is wrong?

Cheers,
tom

?? What are you trying to install?

I was following https://z.cash/download.html and want to install the zcash software

are you wanting to run a node, or linux wallet or mine?

as for the above, I don’t have access at the moment to a linux machine to test, though it should work unless they have a server offline.

Does it matter? For all three tasks I need to install the software. I tried the binary package, but that is also missing some libs
zcashd: /usr/lib/x86_64-linux-gnu/libgomp.so.1: version GOMP_4.0' not found (required by zcashd) zcashd: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: versionGLIBCXX_3.4.20’ not found (required by zcashd)
zcashd: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8’ not found (required by zcashd)

Found out that I also had to install g+±4.9
Now it is working

No you don’t.
if you are doing this as a hobby and just want to see what its about, yes!
if you are GPU mining, nothing there will help you. See link below

just the linux wallet then https://github.com/zcash/zcash/wiki/1.0-User-Guide

Grettings.

I am also having this issue. I want to create a desktop wallet, but when I add the apt source and I update, I get gnutls_handshake() failed: Handshake failed.

I have already done this successfully on my other PC a week ago. I don’t know what have changed or what am I doing wrong

Try first installing/updating the package apt-https-transport. Then do an apt update and try to reinstall zcash. Let us know how that goes.

Hi there,
I’m having the same issue installing zcash on Ubuntu server 14.04.5 LTS.
I tried installing/reinstalling apt-transport-https, and I get the following message:

apt-transport-https is already the newest version.

So I assume it’s ok.

When doing apt-get update, I get:

Err https://apt.z.cash jessie/main i386 Packages
gnutls_handshake() failed: Handshake failed

Also tried using gnutls-cli to get more info, this is result:

fab@smv:~$ gnutls-cli -V -p 443 apt.z.cash
Resolving ‘apt.z.cash’…
Connecting to ‘45.55.14.202:443’…
*** Fatal error: A TLS fatal alert has been received.
*** Received alert [40]: Handshake failed
*** Handshake has failed
GnuTLS error: A TLS fatal alert has been received.

Any additional idea on how to solve this?

Thanks,
mantoz

Not immediately, but we’ll look at this again on Monday.

Are you still having issues with apt updates?

Yes…nothing changed and I still have the same error messages reported above.
Do you have any idea why I’m having a “Handshake failed” message??

Thanks,
mantoz

This is a problem with TLS on Ubuntu 14.04. You can download the package and install from the local package, or install over http rather then https, or I’d recommend updating to a 16.04 LTS if possible.

1 Like

@mantoz did @naimed’s suggestion work for you?

I downloaded the sources (the machine I use is i686 arch, not amd64) and I’m going to compile zcash as soon as I have some spare time. Thanks!

I tried compiling the sources, but I’m stuck here:

make: Entering directory `/home/fab/zcash/depends'
echo Building librustzcash...
Building librustzcash...
mkdir -p /home/fab/zcash/depends/work/build/i686-pc-linux-gnu/librustzcash/0.1-cef814d0cb1/.
cd /home/fab/zcash/depends/work/build/i686-pc-linux-gnu/librustzcash/0.1-cef814d0cb1/.; PATH="/home/fab/zcash/depends/i686-pc-linux-gnu/native/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"   cargo build --frozen --release
/home/fab/zcash/depends/i686-pc-linux-gnu/native/bin/cargo: 1: /home/fab/zcash/depends/i686-pc-linux-gnu/native/bin/cargo:ELF: not found
/home/fab/zcash/depends/i686-pc-linux-gnu/native/bin/cargo: 2: /home/fab/zcash/depends/i686-pc-linux-gnu/native/bin/cargo: Syntax error: ")" unexpected
make: *** [/home/fab/zcash/depends/work/build/i686-pc-linux-gnu/librustzcash/0.1-cef814d0cb1/./.stamp_built] Error 2
make: Leaving directory `/home/fab/zcash/depends'

I think I will give up with this server, waiting to upgrade it to a later Ubuntu LTS release.
This will take (at least) several months, as the server runs several other services which I can’t stop for now.
If possible I’ll do some tests on a more recent distro, as time permits.

Thanks anyway for the support!
mantoz

You should still be able to install on the 14.04 if you download the package and do a local package install. (check the hash of the package of coures.)