Instructions to install from Debian package don't work

I’m using Ubuntu 16.04, with all the latest updates as of 17/09/2018. I’ve followed the instructions on https://zcash.readthedocs.io/en/latest/rtd_pages/install_debian_bin_packages.html#install-debian-bin-packages-guide and I get as far as the final bit where it’s installing and the message is The following NEW packages will be installed: zcash 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 3,823 kB of archives. After this operation, 14.6 MB of additional disk space will be used. Get:1 https://apt.z.cash jessie/main amd64 zcash amd64 2.0.0 [3,823 kB] Fetched 3,823 kB in 3s (1,131 kB/s) Selecting previously unselected package zcash. (Reading database ... 222867 files and directories currently installed.) Preparing to unpack .../archives/zcash_2.0.0_amd64.deb ... Unpacking zcash (2.0.0) ... Processing triggers for man-db (2.7.5-1) ... Setting up zcash (2.0.0) ...

So it looks like everthing is OK, but then the next instruction is

Lastly you can run ./zcash-fetch-params to fetch the zero-knowledge parameters, and set up ~/.zcash/zcash.conf before running Zcash as your local user,

But there is no ./zcash-fetch-params file! In fact I can’t see anything new in my /home/me directory. So where do I go from here?

I have submitted your question to the documentation team, hopefully they will be by soon to help

I’m not 100% sure, but I don’t know that Ubuntu 16.04 is compatible with the Debian instructions.

https://www.datamation.com/open-source/debian-vs-ubuntu-which-is-best-for-you-1.html

This step: git clone https://github.com/zcash/zcash.git cd zcash/ git checkout v2.0.0 ./zcutil/fetch-params.sh

Should have created the parameters folder.

Run zcash-fetch-params (without the ./), the package installs it in /usr/bin

2 Likes

Yes, that’s a typo in the documentation. We’ll get it fixed asap. Did running zcash-fetch-params work?