Issue using copied binaries


#1

Hi

I compiled zcash on a larger linux setup, and then copied the binaries on a more modest setup to see how it goes.

The server starts normaly, but then always fails after a few seconds, without any output in the debug.log :confused:

Here is a sample output of getinfo evolution before crash:

root@scw-e6caeb:~/zcash# ./src/zcash-cli getinfo
{
    "version" : 1000000,
    "protocolversion" : 170002,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 96,
    "timeoffset" : 0,
    "connections" : 1,
    "proxy" : "",
    "difficulty" : 1.50034434,
    "testnet" : true,
    "keypoololdest" : 1473680731,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00005000,
    "errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}
root@scw-e6caeb:~/zcash# ./src/zcash-cli getinfo
{
    "version" : 1000000,
    "protocolversion" : 170002,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 112,
    "timeoffset" : 0,
    "connections" : 1,
    "proxy" : "",
    "difficulty" : 1.79095499,
    "testnet" : true,
    "keypoololdest" : 1473680731,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00005000,
    "errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}
root@scw-e6caeb:~/zcash# ./src/zcash-cli getinfo
{
    "version" : 1000000,
    "protocolversion" : 170002,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 128,
    "timeoffset" : 0,
    "connections" : 1,
    "proxy" : "",
    "difficulty" : 2.26579163,
    "testnet" : true,
    "keypoololdest" : 1473680731,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00005000,
    "errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}
root@scw-e6caeb:~/zcash# ./src/zcash-cli getinfo
{
    "version" : 1000000,
    "protocolversion" : 170002,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 164,
    "timeoffset" : 0,
    "connections" : 1,
    "proxy" : "",
    "difficulty" : 3.11343969,
    "testnet" : true,
    "keypoololdest" : 1473680731,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00005000,
    "errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}
root@scw-e6caeb:~/zcash# ./src/zcash-cli getinfo
error: couldn't connect to server

Hardware info

model name	: Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz
(2 cores used)
2Gb RAM

I've seen Atom benchmark in the wiki, so I guess this is not the issue?


#2

I was able to do this on earlier releases but since then I think there's something to do with ownership permissions that has to be performed - and I'm not that adept at linux to understand the hows and whys. Although I think I've gotten around it by using the same account names on the destination system as the source system.


#3

I did not use the same account, so I moved everything as is with the same user as the one I compiled the program with (along with the relevant chown commands)

No luck though, the daemon still crashes :confused:

Thanks anyway for the idea!


#4

You need more memory if 2 GB is the total. Ubuntu by itself uses 2 GB.


#5

You must be talking about disk space?

2Gb is more than enough to run ubuntu and a bunch of programs - heck there are VPS selling with 0.5Gb RAM with ubuntu :slight_smile:

Also, I was successful not only to run zcash on a Digital Ocean instance with 2Gb, but to compile it as well.

What I don't understand is what's needed to run the same binaries on another instance.


#6

If you don't believe certain Zcash operations (joinsplits and mining in particular) have high memory requirements, open a task monitor and keep an eye on the memory and CPU stats while using Zcash.


#7

I was talking about RAM. I don't know where I got 2 GB RAM for ubuntu but it looked like a good source. I now see them saying 500 MB like you. But I know things are slow and buggy if I try to use only 4 GB RAM with Ubuntu and 4 mining threads on 4 cores.


#8

Since the standard package includes its own copy of GMP (which by default optimizes itself for the machine it's compiled on), it could be a problem with invaild instructions on the Atom machine. You can specifiy the machine to optimize for by passing the --build= option to the configure options in depends/packages/libgmp.mk. For compatibility with all 64 bit Linux PCs I think you would need --build=x86_64-unknown-linux


#9

@zawy I get it, I was talking about server distro, not desktop, and indeed the desktop take a good amount of RAM :slight_smile: So yep the numbers match, more than 2Gb are needed on a desktop to run zcashd, but not on a server which does not run any of the hungry GUI programs


#10

@wildroute thanks !! That must be it!

I'll try to make a 'universal binary' and crunsh some numbers to see if there are any differences, performance wise.