Critical Error on Zcash4win startup

I'm using zcash4win to receive my ZEC mining efforts. I get this error when starting the program:

I don't have much in this wallet, but I'd hate to lose it. I have not backed up the key yet (my fault) so I don't want to uninstall and reinstall the program. I hope someone can help. This error just started all of a sudden and does it every time I try to run it.

Ok, so I've installed the program on a second PC and get another error on first execution:

???????

@anon47418038 is the author of zcash4win , he may be able to help you.

And don't worry, you haven't lost your ZEC, you should be able to go into your​ files to make a copy your wallet.dat file which contains your keys.

zcash4win has not worked for me at all either, ive tried on 3 different systems, the daemon always crashes for me.

TY Shawn - I was able to locate and backup my wallet.dat file. I have successfully installed zcash4win on a 3rd machine, and I have gotten my old wallet into this new installation. I'm d/l'ing the blockchain now. I'd really like to get it sorted on the first PC giving rise to this.

This is a race condition bug when it starts up, usually happens when the blockchain isn't synced all the way. One the first machine (with the GUI STOPPED!) you can start up the zcash daemon in a PowerShell terminal window with this command:

c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1

When its caught up (compare the block height on that screen with the current one at https://zcha.in or https://insight.mercerweiss.com) you can launch the zcash4win GUI, it'll detect that zcashd.exe is already running and connect to it, and in the future it should launch fine.

My man! I will try this immediately when I get back to my shop...THANK YOU!!!

1 Like

no prob...I need to put that in an FAQ!

It's safe to report now that everything is working as it should after rebuilding the blockchain. Thank you!

2 Likes

Hi i seem to be getting the same problem but when putting it in powershell i get
"c:\Program : The term 'c:\Program' is not recognized as the name of a cmdlet, function, script file, or operable
program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ c:\Program Files\zcash4win\app\zcashd -daemon=0 -showmetrics=1
+ ~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (c:\Program:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException"

oh crap it needs to be zdashd.exe not zcashd in that command!

Nogo. I have tried the original "c:\Program Files\zcash4win\app\zcashd.exe -daemon=0 -showmetrics=1" in powershell and I even changed it to zdashd.exe and I continue to get the same error as stated above.

are you typing the quotation marks? because you shouldn't be if you are!
also you can try changing to that directory in powershell with the cd command and then running it as .\zcashd.exe -daemon=0 -showmetrics=1

no quotes I was just separating it so you knew what I was typing

I got a bit farther...

PS C:\Program Files\zcash4win\app> .\zcashd.exe -daemon=0 -showmetrics=1
Before starting zcashd, you need to create a configuration file:
C:\Users\Red Dawn\AppData\Roaming\Zcash\zcash.conf
It can be completely empty! That indicates you are happy with the default
configuration of zcashd. But requiring a configuration file to start ensures
that zcashd won't accidentally compromise your privacy if there was a default
option you needed to change.

You can look at the example configuration file for suggestions of default
options that you may want to change. It should be in one of these locations,
depending on how you installed Zcash:
- Source code: contrib/debian/examples/zcash.conf
- .deb package: /usr/share/doc/zcash/examples/zcash.conf
PS C:\Program Files\zcash4win\app>"

The problem is that file exists...

oh I know what it is now!

It does not like usernames that have a space in them :frowning:
I didn't catch that until now, but it is a known issue and we do not have a fix for it yet aside from running the wallet under another user account, which is not optimal, as its a full node and is a lot happier running all the time, or you have to change your homedir/username so that your homedir does not have a space in the username portion of the file path. I've done it before, but don't have the link handy.

1 Like

Thank you, I will move it to another directory and give it a shot

Hello, I need help! I miss my wallet.
My computer give me bluescreen when zcash4win is synchronized. When I start him after reboot, I have a critical error EOF reached (code 1). I delete all files except wallet.dat and peers.dat. Zcash4win starts. And when it synchronize I make an export private keys. Then I have a new bluescreen. Do all this steps again (without export private keys). But when zcash4win synchronized to 100% I see new adress in my wallet and don't see my zcash. In folder zcash at appdata i have wallet.1500527268.bak. File from export private keys I have too. Can you help me?

I have a similar problem!!!
Tell me, did I understand correctly that on the new machine to restore my wallet I have:

  • install the program zcash4wim
  • copy the file to a folder C:\Users\User\AppData\Roaming\Zcash a file wallet.dat from the old computer
  • run the program and wait for sync

So? Did I miss anything?

That is correct. Honestly, I just backup the whole Zcash folder under AppData so I don’t have to redownload the entire blockchain.

1 Like