Keep Getting Total Shares = 0

Hello,

I finally have my first rig running, but I keep getting Total shares = 0. I’m using Claymore’s zecminer64 for Windows. I’m using a single MSI Radeon RX580. 64GB ssd, 8GB RAM.

I’ve done multiple searches, but doesn’t seem anyone else has asked this question before. Can anyone help this noob?

Thank you,
Rob

Need some more details. What do you have in your bat file? What pool are you connecting to? What does the miner show?

Thank you for your help.

My bat file? There is no file with a .bat extension in the folder containing ZecMiner64.exe. Should I have altered the autoexec.bat file?

But if it helps my config.txt file contains these lines:

-zpool ssl://us1-zcash.flypool.org:3333
-zwal t1bLEUR9M8AGxgWiqCn8AKCgjb5mKNFHDSY
-zpsw z
-benchmark 1
-mport 0
-asm
-tt 75
-i 9

And here is a screen grab of the Total Shares = 0 output:

I greatly appreciate any help or leads you are able to offer!

Rob

Yes there should be a bat file (start.bat). I’m not sure where you’re getting autoexec.bat as that has nothing to do with mining.

Let’s see if we can get some more information.

  • Where did you download Claymore’s miner?
  • Where did you extract the file you downloaded?
  • Can you grab a screenshot of the folder where it’s extracted?

Perhaps your AV software (if you’re running one) may have borked the files.

Note: You may not see the .bat extension if you don’t have Windows Explorer set to show you extensions

My mistake. Yes, there is a start.bat file. Opened it with Notepad. The only text in the file is:

“ZecMiner.exe” (without the quotes)

I downloaded Claymore’s miner from here:
https://drive.google.com/drive/folders/0B69wv2iqszefdmJickl5MF9BOEE

I downloaded “Claymore’s ZCash AMD GPU Miner v12.6-Catalyst 15.12-17.x.zip”.

The path of the folder containing the miner is c:/users/Rob/Programs/Claymore/

Here’s a screen grab:

Thanks again!

Rob

Excellent. So you need to change the start.bat file to include your information. The Readme file is very thorough and will give you all the information you need.

You can also get further instructions from the website of whichever pool you’re running.

If all of what I’ve said above doesn’t make sense to you, you’re probably already in over your head and should do some serious research on what it is you’re doing :slight_smile:

Thank you for the lead. I will check out the readme.txt file. I am only a noob to mining–not computers. I’m 42 and taught myself DOS in the days of dial-up. Editing the start.bat file should be a breeze so long as I know what to put in it.

Thank you!

Rob

Awesome! Glad to hear and you’re welcome. If you get stuck again, don’t hesitate to ask :slight_smile:

Ok, so I already read the readme!!!.txt file last week. I’ve been manually typing in the options in the command line.

For example, when starting the miner, my command line looks like this:

Is there something else I should be doing?

Rob

You don’t need all of those flags. The benchmark one in particular is the reason you’re not able to mine. You’re trying to run in benchmark mode.

Do you have temperature issues? There’s no reason to set any of those flags (-tt, -i, -asm) unless you have an issue. Try the following and see what happens:

ZecMiner64.exe -zpool ssl://us1-zcash.flypool.org:3333 -zwal YourWallet.YourMinerName -zpsw x

What does your miner do?

No, I’m not having temperature issues. That flag was in the config.txt file (as well as a number of other mysterious items, including an unknown wallet address).

Ok, I tried running again using only the string from your example. The good news is that I’m no longer getting a Total Share = 0 message. The bad news is, I’m now getting this:

Hmmmmm…(lightly strokes chin).

What should I do now?

Rob

Looking at Flypool’s website for the information, it looks like you’re using the wrong port.

:wink:

Ok, I’ll look there, too.

Rob

Oh hey, it’s working now! I had the pool address as:

ssl://us1-zcash.flypool.org:3333

But I changed it to the following per the flypool website:

ssl://eu1-zcash.flypool.org:3443

And now it’s working.

Thanks for all your help, nekkidtruth!

Rob

Np. If you’re in the U.S, you can use us1-zcash.flypool.org. The issue is you’re wanting to run in SSL and that requires a different port.

Glad it’s working for you.

Oh ok. Yes, I’d rather use the U.S. one. I’ll try to find the correct port.

Wooooooo!

Rob

1 Like