Mac OS X gui wallet with embedded zcashd BETA

Okay, the daemon now exit when the app is stopped. However, when I restarted the App, it performs a rescan.
Here is the log:

2016-12-09 15:24:58 init message: Verifying blocks...
2016-12-09 15:24:58 Verifying last 288 blocks at level 3
2016-12-09 15:25:15 No coin database inconsistencies in last 289 blocks (1190 transactions)
2016-12-09 15:25:15  block index           18287ms
2016-12-09 15:25:15 init message: Loading wallet...
2016-12-09 15:25:25 nFileVersion = 1000350
2016-12-09 15:25:25 Keys: 113 plaintext, 0 encrypted, 113 w/ metadata, 113 total
2016-12-09 15:25:25 ZKeys: 1 plaintext, 0 encrypted, 1 w/metadata, 1 total
2016-12-09 15:25:25  wallet                10281ms
2016-12-09 15:25:25 init message: Rescanning...
2016-12-09 15:25:25 Rescanning last 712 blocks (from block 23899)...

EDIT: I just tried again two times and it did not performs a rescan.
EDIT 2: Also cli does not freeze on my side.

Amazing work guys.

My node is now crashing once started. I was using it fine for over 40 days straight. I upgraded to 1.0.3 and still the same crash. This is what I see..

Assertion failed: (tree.root() == old_tree_root), function ConnectBlock, file main.cpp, line 2116.
Abort trap: 6

Any ideas?

you may need to launch zcashd with -rescan or -reindex

I'll give that a shot. Thx.

That worked! Thanks radix42!

1 Like

Noob to zCash. Hope you don't mind if I ask a few questions.

So, I downloaded zcash4Mac. Looks cool. App says that it's running and the blockchain is synchronized 100%, etc. All looks normal.

I can generate t and z addresses. They look legit. But, if I check t addresses against the zchain exploerr, https://explorer.zcha.in/accounts, I get 404 errors.

Do I need to install zcashd separately via Linux for this app to work? Do I have to fund the account first? Any help would be appreciated. L

Yeah, unlike most bitcoin block explorers, zcha.in shows a 404 for an address that hasn't been used yet on the zcash blockchain, rather than a page showing no transactions and a zero balance. They work, you just need to fund them first before sending from them.

If you installed the version of zcash4mac from the link above in this post, there's a slightly newer version at: https://zcash4mac.com which is also where (in addition announcements here and on my twitter) new releases will be.

Awesome! Thanks so much for the info. I suspect this is also the reason the address won't work with Shapeshift -- has to be funded first. No worries.

Your app is awesome for Mac users. I spent a few hours wrestling with zcashd on an underpowered VM last night. It's so much better with a GUI. Thanks so much to both of you for putting it together.

Windows is coming soon, too!

I’ve download a wallet from https://zcash4mac.com
and after start got this error

It may need to be installed directly in /Applications and not a
subdirectory. Please try that and report back

thanks, thats work.
another question - if I bakcup my wallet.dat, can I work with it it in official zcash linux command line client?

Yes, the wallet.dat files are binary compatible

hey radix42-

Thanks for porting this over to OSX for us. I opened my wallet tonight and received the following error message. Does this mean my coins are lost? I also tried it with my backup wallet.dat file and I get the same error message.

Oh that is not good, I have only seen that once in the last 6 months, and the wallet file did indeed turn out to be irredeemably corrupted. @daira do you remember that ticket?

Do you have a backup of wallet.dat from before you fired it up after having it off for a while?

I was able to get it fixed using the command you sent me via email and a few other things. I thought you could move the wallet.dat file from one instance to another one, but guess you can’t. I restored the original ZCash folder structure and ran the following command:

/Applications/zcash4mac.app/Contents/Java/zcashd -showmetrics=1 -daemon=0

except zcashd kept crashing:

so I re-ran the command but added -reindex to the end.

/Applications/zcash4mac.app/Contents/Java/zcashd -showmetrics=1 -daemon=0 -reindex

After about 6 hours zcashd sync’d and I launched zcash4mac and my wallet loaded perfectly!! Thank you for your email and help. Definitely sending a donation your way lol…

1 Like

@anon47418038 - wondering if you have any ETA for releasing an update to the Mac GUI wallet with current zcashd?

I'm currently running it after starting zcashd 1.0.8 from the cl, but that's a little cumbersome.

I'm in the same boat, and I know its been a while.....next week?

1 Like

Hi, I am getting the same error message as thesmokingman when I try to open the wallet. Can you guys help me out? I have been using the wallet flawlessly for months. One time before I got that error message. I just restarted my computer and the wallet came back. Now I can’t get in even after restarting and waiting a while. I tried to find that wallet.dat file you guys were talking about but don’t seem to have it anywhere. I had like 8 ZEC on my account =(. Please help.

1 Like