Moving coins between my own transparent accounts


#1

I've been mining for around a day and have 15 unspent transactions as a result, all to different addresses that seem to have been created for each one automatically.

Is this normal, and is there a way so that all the coins I receive are sent to the same address?

I want to move these to a single transparent address, so that I can easily send it all at once to a z address. I haven't been successful in moving any coins from one address to another. Can someone help me? I've looked at 'zcash-cli help', and have tried 'sendfrom' and 'sendtoaddress', but I get "Error: The transaction was rejected![...]" with both. The transactions are all listed as spendable.


#2

The first transaction after coins are generated has to be to a protected address. You might have some repetition ahead of you but follow the beta guide and think of it as good practice. https://github.com/zcash/zcash/wiki/Beta-Guide


#3

Hi, I followed github but I think I made a mistake, where? I'm not able to find it!

./zcash-cli z_sendmany "mtD5xnLedq7Tq37qkc3TuZZWa6tQqUotnn" "[{\"address\": \"tnpgoJLhJ2jvWiFr6AiGbPGMDsgNV7JKH5p2harmexpbLHSvjmPuc748d8zTEib7heJLbF5t9uffbVfwXsHAohveiq2TMJC\", \"memo\": \"prova1\", \"amount\": 0.1}]"
bash: ./zcash-cli: File o directory doesn't exist


#4

Check your path. I usually cd into the zcash directory and then specify the rest of the path needed for each command after that which, for me, is ./src/


#5

@lukeuser I'm also having the same problem and I wasn't able to resolve it following the Beta Guide. But I had a play around and I discovered ZCash is even cooler than I had hoped.

I have set up my T and Z address, I've been successfully mining blocks, when I run 'getinfo' in the CLI I see that I have an account balance of 3.5, but when I run 'listunspent' or 'listtransactions', all the amounts received from finding a block have been sent to different transparent addresses other than initial transparent I set up.

If I try to run:

./src/zcash-cli z_sendmany "$TADDR" "[{\"address\": \"$ZADDR\", \"memo\": \"48656c6c6f20ceb221\", \"amount\": 1.23}]" (from the Beta Guide), I don't have sufficient balances (although my balance is 3.5).

My TADDR is set to the first address I made via getnewaddress "mypaHDPYFVujRD1nRq79g9a1vHsgCsuKct"

The account n2BvB9xKECJMZtYbtxLawX85WpgqjYiyP6 is not my TADDR, but the coins I mined in one block arrived at that address.

https://explorer.testnet.z.cash/tx/352fc0f1618daac72a4831dfa10e66e6a69e6991183bef672bbeb0a38b3036ff

Publicly, there is no balance in this account

https://explorer.testnet.z.cash/address/n2BvB9xKECJMZtYbtxLawX85WpgqjYiyP6

However I was able to use the following to send an amount of 0.6 from this address:

./src/zcash-cli z_sendmany "n2BvB9xKECJMZtYbtxLawX85WpgqjYiyP6" "[{\"address\": \"$ZADDR\", \"memo\": \"48656c6c6f20ceb221\", \"amount\": 0.6}]"

And my balance (via GetInfo) was reduced by 0.6.

It took some time, but I eventually received the coins in my ZADDR using:

./src/zcash-cli z_getbalance "$ZADDR"

I was also able to inspect the transactions using

./src/zcash-cli z_listreceivedbyaddress "$ZADDR"

I'd love to know how I can send an amount in a single transaction from all the mined blocks I have found (all in different addresses) to a single address. I was hoping to donate my coins back to the zcash faucet.

http://faucet.zeropond.com/


#6

I think it takes (or took) 100 confirmations for generated coins to become spendable - maybe your issue was with coins younger than that?


#7

I think the issue is that there isn't a coinbase that can be set with ZCash. I'm still trying to confirm it, but I think its expected that miners should send all mined coins to a protected account. Running ./zcash-cli listunspent will show the amount in the account and that they are spendable.


#8

HI, I've found the mistake, the right command is: ./src/zcash-cli z_sendmany and not ./zcash-cli z_sendmany as in beta guide!!

When I added the src the operation was well done and I got the opid ( operation id)


#9

Just learning the process here but when I intended to send .6 zec it seemed to have sent the whole balance instead?

ub@ub:~/zcash$ ./src/zcash-cli z_sendmany "mt5Tuq6yb6YHUrhShoHoWviBj1bBL9htN5" "[{\"address\": \"$ZADDR\", \"memo\": \"48656c6c6f20ceb221\", \"amount\": 0.6}]"opid-3fa049f0-d79b-4fb0-b064-e729b0820c06
ub@ub:~/zcash$ ./src/zcash-cli z_getbalance "$ZADDR"
0.00000000
ub@ub:~/zcash$ ./src/zcash-cli z_getbalance "$TADDR"
0.00000000
ub@ub:~/zcash$ ./src/zcash-cli z_getbalance "$ZADDR"
0.76990000


#10

This is correct behaviour (for now) as the z_sendmany doesn't let you specify a change address, so it sends the change when protecting coinbase funds to the same zaddr. This behaviour will be reviewed before launch.


#11

which is the meaning of the following fault operation? thanks for any answer. is it not enough 0,1?

sandro@sandro-k550J:~/zcash$ ./src/zcash-cli z_getoperationstatus
[
{
"id" : "opid-4ffe0cef-f2c1-4efa-911f-aada75adf34c",
"status" : "failed",
"creation_time" : 1473801712,
"error" : {
"code" : -6,
"message" : "Insufficient transparent funds, have 10000000, need 0 plus fee 10000"
}
}
]


#12

You must have sent 1ZEC with a balance of 1ZEC, but you have to take into account the needed 0.0001 fee, so instead you should send 0.9999ZEC, anything above that will not be sufficient to pay the transaction fee


#13

hmmm,if so,it will take a long time to wait these coins spendable?
but the confirmaitons of the transaction is 0 for nearly 20min
i think the network is ok

{
"amount" : -0.92340000,
"fee" : -0.00010000,
"confirmations" : 0,
"txid" : "30ed98086e8d0b5f57ede2a6728ba0b947ac3b47ed35ddd962b1e975c2ffd8bc",
"walletconflicts" : [
],
"time" : 1473817485,
"timereceived" : 1473817485,
"details" : [
],


#14

It's already been mined: https://explorer.testnet.z.cash/tx/30ed98086e8d0b5f57ede2a6728ba0b947ac3b47ed35ddd962b1e975c2ffd8bc :slight_smile: