My Hashrate drops from 270.000 Sols, to 40.000 Sols?

Hello, i've begun mining, and i build a small cheap rig with a Powercolor Radeon HD 7970, which i just use for 24/7 ZCash mining via NiceHash.

But the problem is, that when i begin mining, it all seems fine, it tells me i get 270.000 sols, and im earning a stable 1,3$ a day, but then suddenly after a few minutes it drops to 40.000 sols?

I've also discovered that my Core Clock and Memory Clock decreases from
(Core Clock 925Mhz and Memory Clock 1375Mhz) To (Core Clock 500Mhz and Memory Clock 150Mhz)

Temporary fix for this currently is rebooting the PC, but the same problem then occurs a few minutes after!

Im really confused why this is happendning, and i really wanna get it fixed since it has a major impact on the income of my miner.

Please somebody help me :frowning:

I would suggest to use another miner, e.g. Claymore, and check, how the card performs here..

I do not know, what the 7970 delivers in average, but according to various sites, it could be up 290-300 H/s.

According to your description, it also sounds, as if the card powers down automaticall (Heat?), this might also be an issue.

I am already using Claymore_ZCash miner :frowning:

And Yes around 290-300 H/s

And what do you mean by "Powers Down Automaticall Heat?"

@jinsu means your GPU could be heat throttling which means it is getting too hot and is consuming less electricity so that it can cool off.

No it doesnt seem to Throttle nor. overheat. It's at a stable 70 Degress Celcius and 85% Fan speed, and then suddenly i get alot of "GPU 0# RETURNED INCORRECT DATA" and suddenly the hashrate falls to 0 H/s, and then the miner restarts and my clocks are Core 500mhz and Memory 150mhz.

Reducing the intensity could solve the problem.
Take a look into this thread, especially this post:

Thanks, i've read the comments in there and i've lowered the intensity to about the half of my previous, and it seems to have been running smoothly the past hours now, ill sleep over it and write about the progress tommorow.

Also you can try setting this setting to maximum performance