Payment from TADRR to ZADDR not on the chain

Hello,

I've tried to send some ZEC (0.01) form a TADDR in my Wallet to a ZADDR also in my Wallet but it doesn't show on the chain (although I'm synced with it).

I've got a txid : a6c72135f709fd18267b8b859b668feba4b685d88a43a45c3b61707777822fd8 from the operation result.

When I type zcash-cli gettransaction a6c72135f709fd18267b8b859b668feba4b685d88a43a45c3b61707777822fd8, I see that I have 0 confirmation and I made the transaction an hour ago.

When I type getbalance, I can see that the amount has been deducted from my wallet but I can't see it in my ZADDR with z_getbalance.

Is it normal ? Is it related to the fee (I see 0.001 with gettransaction) ?

Thanks a lot

I tried:
zcash-cli getrawtransaction a6c72135f709fd18267b8b859b668feba4b685d88a43a45c3b61707777822fd8

and got:
error code: -5
error message:
No information available about transaction

I don't think there would be an issue with that fee but it seems like the tx did not make it out.

Maybe try sending it again then run:
zcash-cli z_getoperationresult

Thanks for your answer

I've try to send again but a smaller amount (0.001 ZEC). But this time when I run zcash-cli z_getoperationresult I've got the failed status : Insufficient funds, no UTXOs found for taddr from address (I had 0.0169 ZEC +- before my first payment)

However, when i run:
zcash-cli listaddressgroupings

I saw the balance I'm supposed to have after my payment (0.068 ZEC) in another TADRR I've never used (I think i've created it when i first install the Zcash client).

Any idea about why it's not working ?

Well, It seems to me that it's me be related to this problem : https://github.com/zcash/zcash/issues/1705

I can see my tx id among others when i run:
zcash-cli getrawmempool

The other tx get confirmed but mine is still "stuck"

"a6c72135f709fd18267b8b859b668feba4b685d88a43a45c3b61707777822fd8": {
"size": 3419,
"fee": 0.00010000,
"time": 1498268850,
"height": 137218,
"startingpriority": 1e+16,
"currentpriority": 1.000000000000957e+16,
"depends": [
]
},

I'm just starting with Zcash so I'm not sure if its related to this problem.

Is someone has already had this kind of problem ?

Thanks in advance

There is a bug in 1.0.10 that causes it to fail to connect to other nodes. If you're running that version, please downgrade to 1.0.9 for now:

If you installed Zcash using apt-get,

sudo apt-get install zcash=1.0.9

If you built from source, just follow the same instructions as for upgrading in the User Guide: https://github.com/zcash/zcash/wiki/1.0-User-Guide#upgrading