Problem compiling new zcash miner Segmentation fault (core dumped)

I'm trying to compile the new version of the zcash miner but it seems like the method to build it has changed.
I'm using these commands to build it (as directed to in the readme.md)
- Open terminal and run the following commands:
sudo apt-get install cmake build-essential libboost-all-dev
git clone -b Linux https://github.com/nicehash/nheqminer.git
cd nheqminer/cpu_xenoncat/Linux/asm/
sh assemble.sh
cd ../../../Linux_cmake/nheqminer_cpu
cmake .
make -j $(nproc)

everything goes fine up until I get to - sh assemble.sh
and I get this error
~/nheqminer/cpu_xenoncat/Linux/asm$ flat assembler version 1.71.57 (0 kilobytes memory)
-bash: syntax error near unexpected token `('
~/nheqminer/cpu_xenoncat/Linux/asm$ Segmentation fault (core dumped)

any ideas? I'm thinking there might be a problem with the assemble.sh file (based on the syntax error)

For the previous version I was able to compile it using this and it worked fine up until this newest update, now it cant find the make file in nheqminer directory.

sudo apt-get install cmake build-essential libboost-all-dev
git clone https://github.com/nicehash/nheqminer.git12
cd nheqminer/nheqminer
mkdir build
cd build
cmake ..
make

I ran into the same issue. Went back to the previous version, did some research thought yet no definite solution.

It may be that some versions of some libraries were compiled into fasm that don't match the end-system. i.e. Dependencies don't match exactly.

So far I've tried using my local version of fasm, tried playing with memory allocation in assemble.sh, then gave up. I've got 4GRAM so it's not the available memory.

I'm OK using previous (I'm on 0.1c) for now.