Running AWS but 0% CPU usage


#1

Anyone have an idea why I'm getting close to 0% usage in AWS ?

I am monitor through htop and Amazon monitoring software

this is what I have in zcash.conf file

testnet=1
addnode=alphatestnet.z.cash
rpcuser=username
rpcpassword=password
get=1

Blockchain is synced


#2

If that's your exact zcash.conf there's a little typo - it should be 'gen=1' rather than 'get=1'.


#3

Oh damn thanks

FML :slight_smile:


#4

What does "gen=1" mean? Can we set it as get=0 or 2 or other numbers?


#5

gen=1 means start up the mining process


#6

'gen' is an abreviation of 'generate' - and setting the value to 1 instead of 0 enables mining.


#7

If my computer has 4 CPU, can I set gen=4 to let all of these CPU do mining?


#8

procgenlimit=numberofcores

procgenlimit sets the cores

test with
time ~/zcash/src/zcash-cli zcbenchmark solveequihash 10
to see if 1 or 2 or more cores is faster (lower/faster = better)


#9

After I run this command time ~/zcash/src/zcash-cli zcbenchmark solveequihash 10, it got stuck, no output, I tried to run other command like ./zcash-cli getinfo, no output too, it seems this command crashed something.


#10

Give it 10 minutes my runs are

7m33sec 2 core
9m51sec 1 core

m4.large


#11

Does this mean you have 3 cores and then you can set gen=3? And for every process, there should be enough RAM(I suppose it should have 700MB for each process, correct?)


#12

gen=1 is mining on
not using gen= not mining
procgenlimit=1 is 1 core
procgenlimit=2 is 2 cores
procgenlimit=3 is 3 cores etc

gen=1 is used for 1 or 2 or 3 cores (it's always the same)

roughly yes 700mb per core


#13

Very clear, thanks very much.


#14

There is another parameter for the benchmark to test with additional cores but I'm not sure if that functionality is completed in the current version.

This is a much cruder way to find out if mining with additional cores is helpful - note your balance and mine with a single core for 24 hours, note your balance again and mine with two cores for another 24 hours.


#15

This is my testing results, no core numbers....

ubuntu@ip-xxxxxxxxxx:~/zcash/src$ time ./zcash-cli zcbenchmark solveequihash 10
[
{
"runningtime" : 78.28485400
},
{
"runningtime" : 78.37107400
},
{
"runningtime" : 43.68710500
},
{
"runningtime" : 47.61642300
},
{
"runningtime" : 63.68567200
},
{
"runningtime" : 62.88208700
},
{
"runningtime" : 62.61345600
},
{
"runningtime" : 47.42032300
},
{
"runningtime" : 63.17188100
},
{
"runningtime" : 89.63883200
}
]

real 10m37.376s
user 0m0.000s
sys 0m0.004s


#16

no core numbers would mean your only running 1 core (default)

What AWS instance are you running and/or CPU ?


#17

My instance is Ubuntu, I tried to set procgenlimit=2 since I have 2 vCPU and 4 GiB RAM, and get the result as below:
ubuntu@ip-xxxxxxxxx:~/zcash/src$ time ./zcash-cli zcbenchmark solveequihash 10
[
{
"runningtime" : 47.61120700
},
{
"runningtime" : 32.23435400
},
{
"runningtime" : 47.46516200
},
{
"runningtime" : 47.83525400
},
{
"runningtime" : 63.58416900
},
{
"runningtime" : 65.98283200
},
{
"runningtime" : 62.65642200
},
{
"runningtime" : 32.50114200
},
{
"runningtime" : 47.34192500
},
{
"runningtime" : 32.16124400
}
]

real 7m59.378s
user 0m0.000s
sys 0m0.007s


#18

real 7m59.378s (solves 10 runs faster)
real 10m37.376s (solves 10 runs slower)

Im using m4.large and get

real 7m51sec 2 cores (this breaks x4 the blocks in 24hrs)
real 9m33sec 1 cores


#19

I am using t2.medium, it has less 4GiB RAM than m4.large and they both have two vCPU, and we have very close real time(7m59.378s vs 7m51sec), so this proves that more RAM doesn't help much, correct?


#20

The miner isn't optimised enough to be worthwhile to test.